Bug 218422 - No IPv6 support (with patch)
No IPv6 support (with patch)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vnc (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On: 210617
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 04:54 EST by Adam Tkac
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 20:19:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2006-12-05 04:54:52 EST
+++ This bug was initially created as a clone of Bug #210617 +++

Description of problem:
With /etc/hosts like this:

==>
::1    localhost.localdomain    localhost
<==

(as shipped by default in FC6) try this command: vncviewer :1

It fails.

Version-Release number of selected component (if applicable):
4.1.2-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. vncviewer :1
  
Actual results:
unable to resolve host by name: Success (0)

Expected results:
Connection refused.

Additional info:
Patch attached.

-- Additional comment from twaugh@redhat.com on 2006-10-13 07:14 EST --
Created an attachment (id=138416)
vnc-ipv6.patch


-- Additional comment from atkac@redhat.com on 2006-10-13 07:17 EST --
thank you for patch

-- Additional comment from updates@fedora.redhat.com on 2006-10-20 15:26 EST --
vnc-4.1.2-4.fc7 has been pushed for fc5, which should resolve this issue.  If
these problems are still present in this version, then please make note of it in
this bug report.

-- Additional comment from twaugh@redhat.com on 2006-10-23 12:48 EST --
The problem is more apparent in FC6 really.

-- Additional comment from atkac@redhat.com on 2006-10-24 03:50 EST --
(In reply to comment #4)
> The problem is more apparent in FC6 really.

oops, my mistake. vnc-4.1.2-4.fc6 has been pushed for fc6 now. update will be
avaliable in future 2 days
Comment 2 RHEL Product and Program Management 2006-12-05 05:30:20 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 RHEL Product and Program Management 2007-02-07 20:19:50 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.