Bug 210653 - aclocal triggers a warning about an uninitialized variable
aclocal triggers a warning about an uninitialized variable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Brian Brock
:
Depends On:
Blocks: 210668
  Show dependency treegraph
 
Reported: 2006-10-13 11:39 EDT by Stepan Kasal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: autoconf-2.59-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 06:11:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a fix (1.98 KB, patch)
2006-10-13 12:12 EDT, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2006-10-13 11:39:25 EDT
With perl-5.8.8-10 on i686, I see a warning whenever I run aclocal:

Use of uninitialized value in concatenation (.) or string at
/usr/share/autoconf/Autom4te/XFile.pm line 229.

The message does not appear with perl-5.8.8-8 on x86_64.

Lines 216-229 are:
sub lock
{
  my ($fh, $mode) = @_;
  # [...]
  if (!flock ($fh, $mode)

The message comes from the call to "lock" in /usr/bin/autom4te.
(autom4te is executed by aclocal.)

Steps to reproduce:
wget http://ftp.gnu.org/pub/gnu/gawk/gawk-3.1.5.tar.bz2
tar xjf gawk-3.1.5.tar.bz2
cd gawk-3.1.5
aclocal
Comment 1 Stepan Kasal 2006-10-13 12:12:47 EDT
Created attachment 138446 [details]
a fix

The message is triggeted by this: $ENV{'MAKEFLAGS'}

The issue is fixed in autoconf-2.60, where is this patch taken from.
Comment 2 Stepan Kasal 2006-10-13 13:05:43 EDT
There is one factor which I missed previously: the message appears only when
working in a NFS mounted directory.
But then it is triggered by every call to autoconf, automake, autoheader, or
aclocal.
Comment 3 Karsten Hopp 2006-11-02 06:11:11 EST
fixed in FC6, Rawhide and RHEL-5 with autoconf-2.59-12

Note You need to log in before you can comment on or make changes to this bug.