Bug 21071 - up2date fails with "rpm.error: error reading from database"
Summary: up2date fails with "rpm.error: error reading from database"
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-19 13:29 UTC by daniel.deimert
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-19 13:29:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description daniel.deimert 2000-11-19 13:29:27 UTC
When running up2date-2.0.6-1 with the commandline "up2date -a -l",
it fails with the following error message


Removing packages with files marked to skip from list...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 394, in ?
    main()
  File "/usr/sbin/up2date", line 377, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 139, in batchRun
    updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 897, in
getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 854, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 773, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database

Comment 1 Preston Brown 2000-11-28 20:10:48 UTC

*** This bug has been marked as a duplicate of 18994 ***


Note You need to log in before you can comment on or make changes to this bug.