This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 210754 - system-config-lvm / pvmove fails with "ioctl failed: Invalid argument"
system-config-lvm / pvmove fails with "ioctl failed: Invalid argument"
Status: CLOSED DUPLICATE of bug 205818
Product: Fedora
Classification: Fedora
Component: lvm-obsolete (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 06:51 EDT by Roger Bystrøm
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 10:25:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Bystrøm 2006-10-14 06:51:42 EDT
Description of problem:
system-config-lvm trashes sytem when trying to move a partition. It also makes
lvm inaccessible until reboot. 

pvmove however only fails and allows a pvmove --abort to stop the move 

Version-Release number of selected component (if applicable):
  LVM version:     2.02.06 (2006-05-12)
  Library version: 1.02.07 (2006-05-11)
  Driver version:  4.7.0

How reproducible:
always

Steps to Reproduce:
lvm> pvmove -v -n LogVol00 /dev/sdb1 /dev/sda2
    Finding volume group "VolGroup00"
    Archiving volume group "VolGroup00" metadata (seqno 21).
    Creating logical volume pvmove0
    Moving 1000 extents of logical volume VolGroup00/LogVol00
    Found volume group "VolGroup00"
    Updating volume group metadata
    Creating volume group backup "/etc/lvm/backup/VolGroup00" (seqno 22).
    Found volume group "VolGroup00"
    Found volume group "VolGroup00"
    Suspending VolGroup00-LogVol00 (253:0)
    Found volume group "VolGroup00"
    Creating VolGroup00-pvmove0
    Loading VolGroup00-pvmove0 table
  device-mapper: reload ioctl failed: Invalid argument
  ABORTING: Temporary mirror activation failed.  Run pvmove --abort.
    Found volume group "VolGroup00"
    Loading VolGroup00-pvmove0 table
  device-mapper: reload ioctl failed: Invalid argument
    Loading VolGroup00-LogVol00 table
  device-mapper: reload ioctl failed: Invalid argument
lvm> pvmove --abort
  WARNING: dev_open(/dev/sda2) called while suspended
  WARNING: dev_open(/dev/sdb1) called while suspended
  device-mapper: resume ioctl failed: Invalid argument
  Unable to resume VolGroup00-pvmove0 (253:2)

  
Actual results:
If using system-config-lvm the whole system hangs, leaving it unusable and have
to use rescuecd to get it back up.

Expected results:
The partition beeing moved...

Additional info:
According to information on the net it should be sufficient to upgrade to a
newer version of lvm. Not tested by me though.
Comment 1 Kenneth Topp 2006-10-24 11:47:35 EDT
very similar to  #205818
Comment 2 Rahul Sundaram 2006-10-30 10:25:34 EST
Fixing the above bug should resolve this. Marking as duplicate. 

*** This bug has been marked as a duplicate of 205818 ***

Note You need to log in before you can comment on or make changes to this bug.