Bug 210774 - Need ramdisk_blocksize to work
Need ramdisk_blocksize to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-netboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Brich
Fedora Extras Quality Assurance
:
: 219511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 16:58 EDT by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 06:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2006-10-14 16:58:04 EDT
When I upgraded to Rawhide, netboot no longer worked and the kernel gets stuck
in an endless loop, stating "__find_get_block_slow() failed" and completely
funky values.

It did however state that the block size was 4096 bytes. Since initrd usually
uses 1024 bytes, I tried adding ramdisk_blocksize=1024 to the kernel parameters.
An behold, it started to work.

I leave it to you to figure out why and do the necessary tweaks. ;)
Comment 1 ulrich 2007-01-12 06:08:52 EST
*** Bug 219511 has been marked as a duplicate of this bug. ***
Comment 2 Radek Brich 2007-10-17 06:17:42 EDT
fixed in 0.1.42

Note You need to log in before you can comment on or make changes to this bug.