Bug 219511 - diskless kernel panic kernel-smp-2.6.18-1.2239.fc5
Summary: diskless kernel panic kernel-smp-2.6.18-1.2239.fc5
Status: CLOSED DUPLICATE of bug 210774
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-netboot (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
urgent
Target Milestone: ---
Assignee: Fabio Olive Leite
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-13 17:13 UTC by ulrich
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 11:08:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ulrich 2006-12-13 17:13:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):

system-config-netboot-0.1.41
kernel-smp-2.6.18-1.2239

How reproducible:

TFTP/NFS Server:

yum --installroot=/diskless/root install kernel-smp-2.6.18-1.2239.fc5
cd /usr/share/system-config-netboot/diskless
./updateDiskless /diskless/root 2.6.18-1.2239.fc5smp /tmp 
mv /tmp/vmlinuz /tmp/initrd.img /tftplinux/linux-install/fc5
# update ramdisk_size in pxelinux.cfg/default
# initrd.img size calculation from updateDiskless

PXE Client:

Power On,  kernel image and ramdisk ist loaded, kernel boots ....

...
RAMDISK: Compressed image found at block 0
EXT2-fs: blocksize too small for device.
grow_buffers: requested out-of-range block <VERY LARGE NUMBER> for device ram0
No filesystem could mount root, tried: ext2 iso9960
Kernel panic - not syncing ...


Additional Comments:

I have upgraded many kernels this way up to kernel-smp-2.6.17-1.2139_FC5
without problems.

Comment 1 ulrich 2007-01-12 11:08:50 UTC

*** This bug has been marked as a duplicate of 210774 ***


Note You need to log in before you can comment on or make changes to this bug.