Bug 210817 - quirk_via_abnormal_poweroff causes kernel panics on (some?) EPIA boards at boot time
quirk_via_abnormal_poweroff causes kernel panics on (some?) EPIA boards at bo...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 210993 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 14:28 EDT by Lucas Maneos
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 03:22:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Maneos 2006-10-15 14:28:37 EDT
Description of problem:

When booting FC 5.92 on an EPIA EN1200 board the kernel panics.  I can't capture
the console output, but the call trace in the screenshot at
<https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/63134> is
exactly what I'm seeing (modulo timestamps & offsets).

Finally managed to boot the machine with pci=off, did a basic installation and
recompiled the kernel with the contents of the quirk_via_abnormal_poweroff
function commented out, which fixed the problem.

Version-Release number of selected component (if applicable):

Problem is present in all kernels I've tried between whatever version the 5.91
installer comes with and 2.6.18-1.2784.fc6.  5.90 boots fine (but I couldn't get
much further with it due to installer bugs).

How reproducible:

Every time.

Steps to Reproduce:
1. Boot 5.91 or 5.92 installation media or netboot
  
Actual results:

Kernel panic.

Expected results:

Successful boot.

Additional info:
Comment 1 Dave Jones 2006-10-16 13:55:42 EDT
For the release kernel for FC6 (which I'm building today), I've removed this
function.  I'll chase it upstream and see if I can get a better fix out in an
update.
Comment 2 Dave Jones 2006-10-16 19:57:37 EDT
*** Bug 210993 has been marked as a duplicate of this bug. ***
Comment 3 Lucas Maneos 2006-10-17 10:08:17 EDT
Just to confirm, kernel-2.6.18-1.2798.fc6 boots ok.
Comment 4 Dave Jones 2006-10-18 03:22:06 EDT
turns out ACPI is already doing the same thing. So it looks like upstream will
also be removing this function.
Comment 5 Len Brown 2006-10-21 16:26:59 EDT
> Problem is present in all kernels I've tried between whatever
> version the 5.91 installer comes with and 2.6.18-1.2784.fc6.

> Just to confirm, kernel-2.6.18-1.2798.fc6 boots ok.

Lucas, Can you clarify if this means that 2.6.18* always works,
or that at some point it workes and some point it failed like
2.6.17 did?
Comment 6 Lucas Maneos 2006-10-21 19:01:00 EDT
2.6.18-1.2784.fc6 also panicked, until I rebuilt it with
quirk_via_abnormal_poweroff() neutered.  There are no other 2.6.18 kernels in my
yum.log.
Comment 7 Len Brown 2006-10-22 14:25:13 EDT
Thanks, and kernel-2.6.18-1.2798.fc6 worked without any modification?
Comment 8 Lucas Maneos 2006-10-22 18:50:53 EDT
Yes, unmodified straight-out-of-the-rpm kernel-2.6.18-1.2798.fc6 boots without a
panic.

Note You need to log in before you can comment on or make changes to this bug.