Bug 210818 - system-config-packages (part of pirut) reports "Unknown error"
Summary: system-config-packages (part of pirut) reports "Unknown error"
Status: CLOSED DUPLICATE of bug 238118
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-15 18:49 UTC by Kwan Lowe
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 18:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kwan Lowe 2006-10-15 18:49:28 UTC
Description of problem:
The system-config-packages utility reports an error "Unknown Error" when
launched from the command line as a non-root user. This is different behaviour
from the other system-config tools that prompt for the root password.


Version-Release number of selected component (if applicable):
pirut-1.2.5, system-config-packages

How reproducible:
Always

Steps to Reproduce:
1. As a non-root user, start system-config-packages.
2.
3.
  
Actual results:
"Unknown error" dialog appears.

Expected results:
Root authentication dialog or more informative error (e.g., "Only root can
configure packages.").

Additional info:
On FC5, running "pirut" (there's no system-config-packages) seems to work as
expected and prompts for the root PW on the command line.

Comment 1 Jeremy Katz 2006-10-16 00:16:12 UTC
Does running 'pirut' work?

Comment 2 Kwan Lowe 2006-10-16 01:52:34 UTC
thanks for the quick response (on a Sunday even!)...

Yes, pirut works, but it's not nearly as intuitively named as the
system-config-packages link. Within KDE/Gnome (with the Add/Remove Software
link) it's not a big deal, but within Fluxbox or some other minimal environment
(e.g., the twm desktop in the default VNC setup) it wasn't too obvious.

Comment 3 Kwan Lowe 2006-10-19 16:05:24 UTC
There's no system-config-packages pam setting in /etc/pam.d/ and no
/etc/security/console.apps/system-config-packages config. Adding both resolves
my issue.

Comment 4 Matthew Miller 2007-04-06 16:29:18 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 5 Eskil Bylund 2007-04-27 08:37:56 UTC
This bug is still present in F7 Test 4 (I installed from the x86_64 live cd).

Comment 6 John Poelstra 2007-06-06 16:09:21 UTC
system-config-packages fails to start in F7 with "unknown error".  I am starting
it from a command line and running on i386.

pirut-1.3.7-1.fc7

Comment 7 Jeremy Katz 2007-06-13 18:47:39 UTC

*** This bug has been marked as a duplicate of 238118 ***


Note You need to log in before you can comment on or make changes to this bug.