Bug 21089 - gnorpm hangs if behind a firewall
Summary: gnorpm hangs if behind a firewall
Status: CLOSED DUPLICATE of bug 19057
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-19 17:54 UTC by olchansk
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-17 09:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description olchansk 2000-11-19 17:54:41 UTC
On a computer behind a firewall, gnorpm hangs if one tries to
access the "preferences" dialog, for example, to change the http
proxy settings.
   The hang is in a connect() call to tcp/www.redhat.com:80. Such
connections ("direct web browsing") are blocked by our site
firewall. At our site, all outgoing http traffic is required to
go through an http proxy (squid).
   The problem is that it is impossible to tell gnorpm to use
the proxy via the gnorpm preferences gui, because of the
above-described hang.
   Maybe the proxy settings should be added to the gnorpm
command line? At the least, a GUI-less way to specify the proxy
settings should be documented in the gnorpm man page and
in "gnorpm --help" message.

Comment 1 Richard Keech 2000-12-17 09:48:16 UTC
I too find that gnorpm hangs in this situation.
Two workarounds come to mind:

1.	Set an ipchains redirection of port 80 to 8080,

2.	Take down the interface temporarily so allow the options panel of
gnorpm to become available, and set the proxy.

Needs some application-independent way for gnorpm to be aware of the proxy,
perhaps
/etc/sysconfig/proxy.

Comment 2 Jeff Johnson 2001-03-05 21:40:21 UTC

*** This bug has been marked as a duplicate of 19057 ***


Note You need to log in before you can comment on or make changes to this bug.