Bug 19057 - Gnome-RPM 0.95.1-3.rpm fails behind firewall
Summary: Gnome-RPM 0.95.1-3.rpm fails behind firewall
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
: 7960 9254 21089 41055 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 16:03 UTC by Nigel Dallard
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 16:34:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Dallard 2000-10-13 16:03:49 UTC
I've just downloaded and installed gnorpm-0.95.1-3.i386.rpm on to a RedHat
7.0 system. This machine is sitting behind a firewall, so I went to
Operations, Preferences to tell Gnome-RPM about said firewall, but it
insists on trying to download some rdf file from www.redhat.com  before
giving me any option to configure a firewall, so it just sits there until I
kill it.

This was supposed to have been fixed in this release (bugzilla #9254).

Comment 1 Alan Cox 2000-10-14 17:27:06 UTC
Gnorpm works behind firewalls if they correctly reject the connection, if the
connection is simply blocked then it will wait until it times out. Thats rather
a long timeout.

I'll take a look at the preferences issues before gnorpm 1.0 but they are
horribly hard to fix.


Comment 2 Alan Cox 2000-10-14 23:04:09 UTC
*** Bug 9254 has been marked as a duplicate of this bug. ***

Comment 3 Alan Cox 2000-10-14 23:05:52 UTC
*** Bug 7960 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2001-03-05 21:40:17 UTC
*** Bug 21089 has been marked as a duplicate of this bug. ***

Comment 5 Alexander Larsson 2001-08-02 16:34:38 UTC
*** Bug 41055 has been marked as a duplicate of this bug. ***

Comment 6 Alexander Larsson 2002-07-23 16:16:38 UTC
Gnorpm has been deprecated for the next version of RedHat. It will be replaced
with a package called redhat-config-packages.


Comment 7 Mark Warren 2003-05-25 05:16:59 UTC
Another way I found to workaround this problem is to add these lines to the
[rpmfind] section of the file $HOME/.gnome/gnorpm :

 http-proxy=http://my-proxy.mydomain.com:port/
 enableProxy=1



Comment 8 Mark Warren 2003-05-25 05:45:39 UTC
Upon further testing, the enableProxy=1 line isn't necessary.  I just used vi to
manually add the line.


Note You need to log in before you can comment on or make changes to this bug.