This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 211015 - [RHEL5 Beta2] iscsi-initiator-utils: iscsid causes unaligned access on IA64.
[RHEL5 Beta2] iscsi-initiator-utils: iscsid causes unaligned access on IA64.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.0
ia64 Linux
urgent Severity medium
: rc
: ---
Assigned To: Andy Grover
Storage QE
: OtherQA
: 248115 (view as bug list)
Depends On:
Blocks: 228988 391501 668957 445799
  Show dependency treegraph
 
Reported: 2006-10-16 16:05 EDT by Kiyoshi Ueda
Modified: 2012-08-02 18:46 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 18:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kiyoshi Ueda 2006-10-16 16:05:44 EDT
Description of problem:
/etc/init.d/iscsi causes unaligned access on IA64.
It's enabled by default.


Version-Release number of selected component:
iscsi-initiator-utils-6.2.0.695-0.5


How reproducible:
Always


Steps to Reproduce:
 1. /etc/init.d/iscsi restart


Actual results:
iscsid causes unaligned access.
---------------------------------------------------------------------
Oct 16 14:10:36 nec-tx7-2 kernel: iscsid(5530): unaligned access to
0x2000000000400101, ip=0x4000000000012e61
Oct 16 14:10:36 nec-tx7-2 kernel: iscsid(5530): unaligned access to
0x2000000000400101, ip=0x4000000000012e71
Oct 16 14:10:37 nec-tx7-2 iscsid: caught signal -15, ignoring...
Oct 16 14:10:41 nec-tx7-2 kernel: Loading iSCSI transport class
v2.0-685.<5>iscsi: registered transport (tcp)
Oct 16 14:10:41 nec-tx7-2 iscsid: iSCSI logger with pid=5895 started!
Oct 16 14:10:41 nec-tx7-2 kernel: iscsid(5894): unaligned access to
0x2000000000400059, ip=0x4000000000012e71
Oct 16 14:10:41 nec-tx7-2 kernel: iscsid(5896): unaligned access to
0x2000000000400059, ip=0x4000000000012e61
Oct 16 14:10:41 nec-tx7-2 kernel: iscsid(5896): unaligned access to
0x2000000000400095, ip=0x4000000000012e71
Oct 16 14:10:42 nec-tx7-2 iscsid: transport class version 2.0-685. iscsid
version 2.0-695
Oct 16 14:10:42 nec-tx7-2 iscsid: iSCSI daemon with pid=5896 started!
Oct 16 14:10:42 nec-tx7-2 iscsid: an InitiatorAlias= is required, but was not
found in /etc/iscsi/initiatorname.iscsi
Oct 16 14:10:42 nec-tx7-2 iscsid: iSCSI sync pid=5901 started
---------------------------------------------------------------------


Expected results:
iscsid should not cause unaligned access.


Additional info:
Comment 1 Mike Christie 2006-10-16 16:19:37 EDT
What kernel version are you running with? Do a uname -a?

Does this also only occur on restart? Does it occur if you startup iscsi and
setup sessions?
Comment 2 Kiyoshi Ueda 2006-10-16 16:50:24 EDT
I tried kernel-2.6.18-1.2717.el5 and kernel-2.6.18-1.2727.el5.

This occurs on start and stop.
It seems to occur on "daemon iscsid" and "killproc iscsid".

And I found that this occurs by:
  # modprobe iscsi_tcp
  # iscsid
Comment 3 Mike Christie 2006-10-16 17:15:25 EDT
Are you the same NEC people in westfird? Is this box in Red Hat somewhere by any
chance?
Comment 8 Mike Christie 2007-11-14 12:37:25 EST
*** Bug 248115 has been marked as a duplicate of this bug. ***
Comment 10 Jun'ichi Nomura (Red Hat) 2008-03-17 16:24:59 EDT
Not reproduced when testing with the latest nightly build including:
kernel-2.6.18-85.el5
iscsi-initiator-utils-6.2.0.868-0.3.el5
Comment 11 Mike Christie 2008-03-17 18:11:28 EDT
There are still some in the logout or error handler paths though. I am going to
fix them up in 5.3, so please keep this bug open.
Comment 13 RHEL Product and Program Management 2008-06-02 16:42:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 Mike Christie 2008-10-22 12:47:47 EDT
I was not able to do a big update to iscsi-initiatior-utils and bring all the fixes I wanted. I am moving this to 5.4.
Comment 17 Debbie Johnson 2009-06-19 08:18:22 EDT
Sorry for delayed response..., but could you let me know about your tested version? I'll try it.

As same as iscsi-initiator-utils-6.2.0.695-0.5 ?
---- #16 on Bug 211015
This is hard to reproduce, and may in fact have been fixed. Moving to 5.5, while we await confirmation.
---- 

(Copied from IT)
Comment 22 RHEL Product and Program Management 2010-08-09 14:43:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 24 RHEL Product and Program Management 2011-01-11 16:13:16 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 25 RHEL Product and Program Management 2011-01-11 17:39:51 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 28 RHEL Product and Program Management 2011-06-21 01:52:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.7 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 30 Masaki Furuta 2011-06-23 00:49:19 EDT
Info:

re-targeting 5.8.
Comment 33 RHEL Product and Program Management 2012-04-02 06:32:34 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 40 RHEL Product and Program Management 2012-08-02 18:46:19 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.