Bug 211223 - Kernel BUG at mm/slab.c, connecting N61 mobile phone via USB
Kernel BUG at mm/slab.c, connecting N61 mobile phone via USB
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 217445 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 17:40 EDT by Fernando Fernandez Pedraza
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 17:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Fernandez Pedraza 2006-10-17 17:40:08 EDT
Description of problem: 

Version-Release number of selected component (if applicable):
2.6.18-1.2200.fc5 #1 SMP

How reproducible:
always

Steps to Reproduce:
1. Connect Nokia e61 mobile phone via USB
2. kernel error

  
Actual results:

This in /var/log/messages and not able to sync device:

Oct 17 23:19:58 ciberiada2 kernel: ohci_hcd 0000:00:02.0: wakeup
Oct 17 23:19:59 ciberiada2 kernel: usb 2-5: new full speed USB device using
ohci_hcd and address 2
Oct 17 23:19:59 ciberiada2 kernel: usb 2-5: configuration #1 chosen from 1 choice
Oct 17 23:20:00 ciberiada2 kernel: cdc_acm 2-5:1.10: ttyACM0: USB ACM device
Oct 17 23:20:00 ciberiada2 kernel: usbcore: registered new driver cdc_acm
Oct 17 23:20:00 ciberiada2 kernel: drivers/usb/class/cdc-acm.c: v0.25:USB
Abstract Control Model driver for USB modems and ISDN adapters
Oct 17 23:20:00 ciberiada2 kernel: usbcore: registered new driver cdc_ether
Oct 17 23:20:01 ciberiada2 kernel: rndis_host 2-5:1.12: RNDIS init failed, -32
Oct 17 23:20:01 ciberiada2 kernel: usb%d: unregister 'rndis_host'
usb-0000:00:02.0-5, RNDIS device
Oct 17 23:20:01 ciberiada2 kernel: ----------- [cut here ] --------- [please
bite here ] ---------
Oct 17 23:20:01 ciberiada2 kernel: Kernel BUG at mm/slab.c:594
Oct 17 23:20:01 ciberiada2 kernel: invalid opcode: 0000 [1] SMP 
Oct 17 23:20:01 ciberiada2 kernel: last sysfs file: /class/net/eth0/carrier
Oct 17 23:20:01 ciberiada2 kernel: CPU 0 
Oct 17 23:20:01 ciberiada2 kernel: Modules linked in: rndis_host cdc_ether
usbnet cdc_acm autofs4 xt_tcpudp iptable_filter ip_tables x_tables dm_mirror
dm_mod video sbs i2c_ec button battery asus_acpi ac lp parport_pc parport
usb_storage sg nvidia(U) ohci_hcd ehci_hcd serio_raw snd_intel8x0 snd_ac97_codec
snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device
snd_pcm_oss snd_mixer_oss snd_pcm k8_edac edac_mc forcedeth ide_cd cdrom
i2c_nforce2 i2c_core pcspkr shpchp snd_timer snd soundcore snd_page_alloc ext3
jbd sata_nv libata sd_mod scsi_mod
Oct 17 23:20:01 ciberiada2 kernel: Pid: 2499, comm: modprobe Tainted: P     
2.6.18-1.2200.fc5 #1
Oct 17 23:20:01 ciberiada2 kernel: RIP: 0010:[<ffffffff8020af93>] 
[<ffffffff8020af93>] kfree+0x8b/0x211
Oct 17 23:20:01 ciberiada2 kernel: RSP: 0018:ffff81002a1cfc78  EFLAGS: 00010006
Oct 17 23:20:01 ciberiada2 kernel: RAX: 0000000000000060 RBX: 00000000ffffffe0
RCX: 0000000000000006
Oct 17 23:20:01 ciberiada2 kernel: RDX: ffff810001c22bc0 RSI: ffff810001000030
RDI: ffff81003086fbad
Oct 17 23:20:01 ciberiada2 kernel: RBP: ffff81002f24e388 R08: ffff810029e3c000
R09: ffff810029e00780
Oct 17 23:20:01 ciberiada2 kernel: R10: 00000000ffffffe0 R11: 0000000000000000
R12: ffff81003086fbad
Oct 17 23:20:01 ciberiada2 kernel: R13: ffff810030875000 R14: 0000000000000282
R15: 0000000000000000
Oct 17 23:20:01 ciberiada2 kernel: FS:  00002aaaaaacf210(0000)
GS:ffffffff80605000(0000) knlGS:0000000000000000
Oct 17 23:20:01 ciberiada2 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Oct 17 23:20:01 ciberiada2 kernel: CR2: 00007ffff9750170 CR3: 0000000029e4a000
CR4: 00000000000006e0
Oct 17 23:20:01 ciberiada2 udevd-event[2494]: run_program: '/sbin/modprobe'
abnormal exit
Oct 17 23:20:01 ciberiada2 kernel: Process modprobe (pid: 2499, threadinfo
ffff81002a1ce000, task ffff8100250d0810)
Oct 17 23:20:01 ciberiada2 kernel: Stack:  00000000fffffff4 ffff810030875770
00000000ffffffe0 ffff81002f24e388
Oct 17 23:20:01 ciberiada2 kernel:  ffff810030875580 ffff810030875000
0000000000000000 ffffffff8890a298
Oct 17 23:20:01 ciberiada2 kernel:  0000000000002ee2 ffff8100250d0a00
ffff810000000000 ffff81003f4af040
Oct 17 23:20:01 ciberiada2 kernel: Call Trace:
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff8890a298>]
:usbnet:usbnet_probe+0x608/0x62f
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803d625f>]
usb_probe_interface+0x6c/0x9e
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803a48c5>]
driver_probe_device+0x52/0xa2
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803a4a1e>] __driver_attach+0x86/0xd4
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803a42d9>] bus_for_each_dev+0x43/0x6e
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803a3f1c>] bus_add_driver+0x7e/0x130
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff803d610e>]
usb_register_driver+0x74/0xd6
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff802a3306>]
sys_init_module+0x1708/0x18cc
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff8025c1ce>] system_call+0x7e/0x83
Oct 17 23:20:01 ciberiada2 kernel: DWARF2 unwinder stuck at system_call+0x7e/0x83
Oct 17 23:20:01 ciberiada2 kernel: Leftover inexact backtrace:
Oct 17 23:20:01 ciberiada2 kernel: 
Oct 17 23:20:01 ciberiada2 kernel: 
Oct 17 23:20:01 ciberiada2 kernel: Code: 0f 0b 68 6c 2a 48 80 c2 52 02 4c 8b 6a
30 65 8b 04 25 2c 00 
Oct 17 23:20:01 ciberiada2 kernel: RIP  [<ffffffff8020af93>] kfree+0x8b/0x211
Oct 17 23:20:01 ciberiada2 kernel:  RSP <ffff81002a1cfc78>
Oct 17 23:20:01 ciberiada2 kernel:  <3>BUG: sleeping function called from
invalid context at kernel/rwsem.c:20
Oct 17 23:20:01 ciberiada2 kernel: in_atomic():0, irqs_disabled():1
Oct 17 23:20:01 ciberiada2 kernel: 
Oct 17 23:20:01 ciberiada2 kernel: Call Trace:
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff80269387>] show_trace+0x34/0x47
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff802693ac>] dump_stack+0x12/0x17
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff8029dcd2>] down_read+0x15/0x23
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff802962c0>]
blocking_notifier_call_chain+0x13/0x36
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff80214e75>] do_exit+0x1f/0x8c3
Oct 17 23:20:01 ciberiada2 kernel:  [<ffffffff8026969f>] kernel_math_error+0x0/0x90


Expected results:
No errors and device works

Additional info:
Single core Athlon 64 CPU
Comment 1 Dave Jones 2006-10-19 17:14:42 EDT
There have been numerous reports of bugs in mm/slab.c triggering when the nvidia
module is loaded.   Unfortunatly they have our source, but we don't have theirs.

Only nvidia can fix this problem.
Comment 2 Frederik Hertzum 2006-11-27 21:54:50 EST
*** Bug 217445 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.