Bug 211266 - Arabic input assumes US kbd layout
Arabic input assumes US kbd layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim-m17n (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n, MoveUpstream, Reopened
Depends On:
Blocks: 228947
  Show dependency treegraph
 
Reported: 2006-10-18 05:36 EDT by Carl-Johan Kjellander
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: scim-m17n-0.2.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 23:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scim arabic input (119.01 KB, image/png)
2007-01-16 14:38 EST, Ramakrishna Reddy Yekulla
no flags Details
the svlatin1 and arabic keysequences (121.70 KB, image/png)
2007-01-17 01:07 EST, Ramakrishna Reddy Yekulla
no flags Details

  None (edit)
Description Carl-Johan Kjellander 2006-10-18 05:36:39 EDT
Description of problem:
When installing FC6test4 with a sv_latin1 keyboard, arabic input
doesn't work after install for (at least) 4 keys that are needed for arabic,
but also used in Swedish.

Version-Release number of selected component (if applicable):
scim-1.4.4-35.fc6

How reproducible:
All the time.

Steps to Reproduce:
1. Install FC6test4
2. Select sv_latin1 as keyboard during installation
3. Open any program that takes input, like gedit.
4. Select the input method 'Arabic (Egypt)'
5. Try the two keys right of 'P', and right of 'L'

  
Actual results:
It inputs 'å~öä', which are the Swedish letters for those keys.

Expected results:
It should input the arabic letters for 'k' and some others.

Additional info:
The rest of the qwerty-keys seem to work.
Comment 1 Jens Petersen 2006-10-18 19:48:03 EDT
Yes, this is a limitation of current scim and m17n.
The problem is as you indirectly imply that the m17n map basically
assumes a US keyboard layout.
Comment 2 Jens Petersen 2006-10-18 20:01:05 EDT
Carl-Johan, are you also using scim to input other languages?
If you're only using scim to input Arabic you might find it
either to switch between Swedish and Arabic xkbd layouts instead
as a workaround for now.
Comment 3 Jens Petersen 2006-10-18 20:11:14 EDT
Alternatively you can edit ar-kbd.mim from the m17n-db package
to suit your keyboard layout but of course this is not a portable/
maintainably solution.
Comment 4 Jens Petersen 2006-10-18 20:13:07 EDT
Mail sent to scim-devel and m17n-lib.
Comment 5 Carl-Johan Kjellander 2006-10-18 21:11:09 EDT
Why doesn't scim use the actual keycodes?!

That's what it should do. Who cares what the american's keyboard looks
like when you are typing arabic?

Anyway, for me it's not at problem. I'm only using Japanese, Georgian and
Arabic input methods for fun (in windows right now, cause it works, even
though I hate it). I have students from all over the world.

But making a fix for _real_ should probably be a priority. Portable,
and independent of what the american keyboard thinks is the best way 
to slow people down so the types of the typewriter don't stick together.
(note my irony...)

So to answer your question, yes, I use scim to try to input more than
swedish and arabic. I need japanese since I study it and georgian and
russian and greek would be nice.
Comment 6 Jens Petersen 2006-10-18 21:31:48 EDT
> Why doesn't scim use the actual keycodes?!

I guess the problem is not so easy to solve.
What do you want keys not mapped by the input map to map to for example?
It can get pretty confusing I guess: right now I have a US keyboard connected
to my JP laptop and it is no fun I can reassure you...

Also it is much harder to write maps for keycodes than keysymbols,
but there should be some cleverer solution so I have asked upstream
on this for ideas.
Comment 7 Jens Petersen 2006-10-23 23:50:53 EDT
Adding patch from upstream in scim-m17n-0.2.1-1.fc7.
Comment 8 Jens Petersen 2006-10-27 02:12:24 EDT
Carl, are you able to test that?
Comment 9 Carl-Johan Kjellander 2006-10-28 07:19:36 EDT
I tested it a few days ago.

$ rpm -q scim-m17n
scim-m17n-0.2.1-1.fc7

I installed to rpm and logged out and in again. Setting it to arabic still
produces åäö instead of the correct arabic characters. And ^ is still a
dead key.

It should be enough to log out of X right?
Comment 10 Jens Petersen 2006-10-29 23:14:07 EST
Sorry, could you try setting the scim keyboard type to Swedish too please?
Comment 11 Carl-Johan Kjellander 2006-10-30 14:57:19 EST
With Swedish, åäö works fine, but dead keys ^~'` and so forth are broken.
Impossible to input. And pressing 'e' produces a line that follows the last e
which is very confusing.

And I just realized there is something wrong with the sv-latin keymap.
I can't produce the '¨' even when scim is off, by pressing CTRL-SPACE.
Here is xev output:

KeyPress event, serial 28, synthetic NO, window 0x4c00001,
    root 0x4d, subw 0x0, time 2596938031, (150,144), root:(1563,698),
    state 0x10, keycode 35 (keysym 0xfe57, dead_diaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c2 a8) "¨"
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: True

KeyRelease event, serial 31, synthetic NO, window 0x4c00001,
    root 0x4d, subw 0x0, time 2596938171, (150,144), root:(1563,698),
    state 0x10, keycode 35 (keysym 0xfe57, dead_diaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c2 a8) "¨"
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x4c00001,
    root 0x4d, subw 0x0, time 2596939617, (150,144), root:(1563,698),
    state 0x10, keycode 65 (keysym 0x20, space), same_screen YES,
    XLookupString gives 1 bytes: (20) " "
    XmbLookupString gives 1 bytes: (20) " "
    XFilterEvent returns: True

KeyPress event, serial 31, synthetic NO, window 0x4c00001,
    root 0x4d, subw 0x0, time 2596939617, (150,144), root:(1563,698),
    state 0x10, keycode 0 (keysym 0x22, quotedbl), same_screen YES,
    XKeysymToKeycode returns keycode: 11
    XLookupString gives 0 bytes: 
    XmbLookupString gives 1 bytes: (22) """
    XFilterEvent returns: False

Pressing it and space produces a '"' instead.
Comment 12 Jens Petersen 2006-10-31 03:32:58 EST
BTW how to set the Swedish kbd with setxkbmap?  (Last time I did it with
the gnome panel applet I think.)
Comment 13 Carl-Johan Kjellander 2006-10-31 04:56:20 EST
System/Preferences/Keyboard/Layout

system-config-keyboard does it as well.
Comment 14 Jens Petersen 2006-10-31 20:54:44 EST
Thanks for testing.  I tried too and agree it doesn't fix the problem.
Comment 15 Jens Petersen 2006-11-19 20:16:04 EST
I retested this today after some discussion on scim-devel and now it is
working for me: perhaps rebooting helped.
Comment 16 Jens Petersen 2006-11-19 20:16:53 EST
Just for reference: one can switch to Swedish layout with "setxkbmap se".
Comment 17 Ramakrishna Reddy Yekulla 2007-01-16 14:38:57 EST
Created attachment 145721 [details]
scim arabic input

Arabic input works fine, as shown in the attached figure. attached are both the
sequences for arabic, scim-arabic and arabic -kdb
Comment 18 Carl-Johan Kjellander 2007-01-16 22:14:32 EST
Ramakrishna: Were those pictures taken with "setxkbmap se" or not? I want to
see some "åäö" being input at the same time as the three arabic letters that
I can't produce.

Try to enter 'Mötley Crüe' for instance.
Comment 20 Ramakrishna Reddy Yekulla 2007-01-17 01:07:16 EST
Created attachment 145775 [details]
the svlatin1 and arabic keysequences

Steps to reproduce
1. Alt F2 or gnome-terminal
2. system-config-keyboard
3. Select the Sweden Northan Saami
4. Add the Arabic Qwerty and azerty keyboard from layout options 
4. Toggle between US <->SWE <-> Arabic The sequences are shown in the attached
screenshot
The keymaps work fine. This bug can be resolved
Comment 21 Carl-Johan Kjellander 2007-02-15 10:19:41 EST
I beg to differ.

Yes, by adding arabic as a keyboard layout you can work around the
bug, but it doesn't solve the underlying problem, that scim assumes
everyone lives in the US and has ;'[ instead of öäå on some keys.

And using scim was supposed be a fix all system to solve all keyboard
problems.

Having as it is now two ways of selecting the keyboard is very confusing.

And still, if you have Swedish selected, scim is fundamentaly broken,
and you have to use both the keyboard switcher applet and scims toolbar.
Comment 22 Jens Petersen 2007-02-15 21:22:43 EST
Carl-Johan, I retested the fix now, and I find that is works with
the scim immodule, but not with scim-bridge.  I agree that this is
important issue and want to backport the fixes to FC6 when ready.
And thanks for reporting it. :-)

I cloned a bug for scim-bridge.
Comment 23 Jens Petersen 2007-03-08 00:50:40 EST
Update for scim-bridge has been pushed for FC6.

I built scim-m17n-0.2.1-1.fc6 for FC6 updates.
Comment 24 Fedora Update System 2007-03-12 15:15:47 EDT
scim-m17n-0.2.1-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.