Bug 211385 - automatic opening of consoles
automatic opening of consoles
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
Brian Brock
: FutureFeature
Depends On:
Blocks: 212024
  Show dependency treegraph
 
Reported: 2006-10-18 17:13 EDT by Ulrich Drepper
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:27:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2006-10-18 17:13:06 EDT
Description of problem:
virt-manager currently only opens the windows (graphical and text console) for a
domain on demand.  This is problematic if the domain crashes and one wants to
know why.  It also is needed if a message during startup has to be observed. 
Opening the window by hand menas some information gets lost.

A feature is needed to select that for all newly started domains (or a subset)
the graphical and/or text console are opened automatically.  This would allow
all the output to be seen.


Version-Release number of selected component (if applicable):
virt-manager-0.2.3-2.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The fact that this feature request comes late should not be held against it. 
This is a usability issue which only is discovered when the program is in use. 
It is also needed when the stability of xen isn't too high.  Unfortunately this
is the case in the moment and we need all the help we can get.
Comment 1 Daniel Berrange 2006-11-06 14:14:43 EST
Finally finished the implementation of this feature upstream. As well as setting
up to auto-open consoles, needed to have code to auto-retry the VNC connection
since we'd often popup the console before the Xen VNC daemon started. Upstream
changeset is

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=52d0377abcb8
Comment 4 Jay Turner 2006-11-28 11:27:05 EST
QE ack for RHEL5.
Comment 6 Daniel Berrange 2006-11-30 13:40:24 EST
Fix built for RHEL-5

* Tue Nov 28 2006 Hugh O. Brock <hbrock@redhat.com> - 0.2.5-3.el5
- Add automatic console popups on launching a VM, plus a few console fixes (bz
211385)

$ brew latest-pkg dist-5E virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.2.5-3.el5                  dist-5E               hbrock
Comment 7 RHEL Product and Program Management 2006-12-22 20:27:23 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.