Bug 211449 - grep returns glibc error
grep returns glibc error
Status: CLOSED DUPLICATE of bug 202991
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 07:47 EDT by Wade Lewis
Modified: 2016-11-24 10:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 08:36:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Lewis 2006-10-19 07:47:42 EDT
Description of problem:

When using grep with the "-i" option on a certain pdf file it will return this:

"*** glibc detected *** free(): invalid next size (fast): 0x08530250 ***"

I've tested on multiple pdf files and haven't been able to repeat this. Here is
the backtrace output from gdb:

(no debugging symbols found)
*** glibc detected *** free(): invalid next size (fast): 0x0987d250 ***
Program received signal SIGABRT, Aborted.
(gdb) where
#0  0x001687a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x001a87a5 in raise () from /lib/tls/libc.so.6
#2  0x001aa209 in abort () from /lib/tls/libc.so.6
#3  0x001dc71a in __libc_message () from /lib/tls/libc.so.6
#4  0x001e2fbf in _int_free () from /lib/tls/libc.so.6
#5  0x001e333a in free () from /lib/tls/libc.so.6
#6  0x0022ace0 in re_search_internal () from /lib/tls/libc.so.6
#7  0x0022d1b3 in re_search_stub () from /lib/tls/libc.so.6
#8  0x0022d623 in re_search () from /lib/tls/libc.so.6
#9  0x080546df in ?? ()
#10 0x0987c970 in ?? ()
#11 0x09880490 in ?? ()
#12 0x000002ef in ?? ()
#13 0x00000000 in ?? ()

I haven't tried using grep on a different a machine as this is a client's pdf
and at the moment it isn't possible. Additionally, it seems to be related to the
number of characters that is searched for, example:

grep -i mysql_connect file.pdf
grep -i qawse_rftgyht file.pdf

produces the exact same results, however

grep -i blah file.pdf returns nothing as expected.

Last, I've tried other pdf files while grepping for a case insensitive 13
character string and it does not fail, so it seems to be a combination of the
number of characters and this pdf file. 

The rpm verify of all glibc and grep packages returns nothing so I have verified
these packages have not been modified.


Version-Release number of selected component (if applicable):
ES4 update 4

How reproducible:
I'll talk with the client to see whether the pdf file can be uploaded


Steps to Reproduce:
1.grep -i blah
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-10-19 08:36:21 EDT

*** This bug has been marked as a duplicate of 202991 ***

Note You need to log in before you can comment on or make changes to this bug.