Bug 211469 - RFE: flag for clusvcadm to respect failover domain priorities (rhcs5)
RFE: flag for clusvcadm to respect failover domain priorities (rhcs5)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 11:57 EDT by Lon Hohberger
Modified: 2009-04-16 18:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0580
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:45:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Respect failover patch against rgmanager-2.0.24 (7.75 KB, patch)
2007-06-13 15:36 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2006-10-19 11:57:33 EDT
+++ This bug was initially created as a clone of Bug #210482 +++

Description of problem:
SSIA, instead of what is specified in /etc/cluster/cluster.conf, "clusvcadm -e
<service>" starts <service> on the local node.

Version-Release number of selected component (if applicable):
rgmanager-1.9.53

How reproducible:
Easy

Steps to Reproduce:
1. "clusvcadm -e <service>"
  
Actual results:
<service> gets started on local node

Expected results:
<service> should be started on a node in the cluster that satisfies constraints
specified in cluster.conf, e.g. priority.

Additional info:

-- Additional comment from lhh@redhat.com on 2006-10-17 10:23 EST --
Expected behavior.  Use the -n <nodename> flag.  You can use clusvcadm to
explicitly start the service where you want, otherwise, the assumption is that
the service should be started locally.

The failover domain priority is used for cluster-induced service transitions
(which happen after node transitions), and is not used for user-induced
enable/disable requests.

It may be possible to add a flag to clusvcadm to do this (for 'use failover
domain priority, if possible') in a future release, but the current behavior is
not a bug.

However, the basic behavior for '-e' is correct.





-- Additional comment from nphilipp@redhat.com on 2006-10-17 11:44 EST --
This should be mentioned in "clusvcadm --help" somewhere, the people I've
encountered seem to expect "clusvcadm" to respect the constraints in
cluster.conf when using "-e". Should I open a new BZ item for an RFE?
Comment 3 Kiersten (Kerri) Anderson 2007-04-23 13:25:10 EDT
Fixing Product Name.  Cluster Suite was integrated into the Enterprise Linux for
version 5.0.
Comment 4 RHEL Product and Program Management 2007-04-25 19:13:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Marek Grac 2007-06-04 09:28:33 EDT
There is a different behaviour implemented. 
RHEL4:
-e: ignore failover domains 
-f: run on the node in the failoved domain (command can be executed elsewhere)

RHEL5 (current status):
-e: do not ignore failover domains. if there is an attempt to execute it
elsewhere then 'Failure'. 
Comment 6 Marek Grac 2007-06-13 15:36:34 EDT
Created attachment 156908 [details]
Respect failover patch against rgmanager-2.0.24

This patch add -F option to enable respect failover (clusvcadm -Fe service00).
It also changes behaviour of -e to be same as in RHEL4 (clusvcadm -e service00
will start service locally even if we are not a part of failover domain)
Comment 7 Marek Grac 2007-06-14 10:13:57 EDT
Patch is in the CVS branch RHEL50
Comment 11 Lon Hohberger 2007-06-29 13:07:55 EDT
This is a new feature.  As such, no regression testing is available.  To test
the new feature, create an ordered failover domain of at least one node and bind
a service to it in cluster.conf.

<rm>
  <failoverdomains
    <failoverdomain name="foo">
      <failoverdomainnode name="node1" ordered="1"/>
    </failoverdomain>
  </failoverdomains>

  <service name="footest" domain="foo"/>
</rm>

The service does not require any child resources.  In at least a two node
cluster on node2, run:

   clusvcadm -e footest.

The service will start on node2.  This can be verified using the 'clustat' utility.

Run the following from either node:
   clusvcadm -d footest.

The service will be put in to the disabled state.  This can be verified using
the 'clustat' utility.

finally, run the following

   clusvcadm -Fe footest

The service should be started on node1 - even when run from node2, due to the
failover domain constraints.
Comment 13 errata-xmlrpc 2007-11-07 11:45:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html

Note You need to log in before you can comment on or make changes to this bug.