Bug 211680 - 'Hotplug scripts not working' error
'Hotplug scripts not working' error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Stephen Tweedie
:
: 211681 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 15:22 EDT by Tim Boyer
Modified: 2008-03-12 08:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 08:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Boyer 2006-10-20 15:22:50 EDT
Description of problem:

When taking baby steps on getting a xen client going, the error 
message 'Error: Device 769 (vbd) could not be connected. Hotplug scripts not 
working.' appears:

[root@buran xen]# xm create -c myxen vmid=1
Using config file "myxen".
Error: Device 769 (vbd) could not be connected. Hotplug scripts not working.

'myxen' is the stock xmexample1 script - only thing changed is the name of the 
kernel image.  And since my disks are sda and sdb, the default disk drive 
didn't exist.

Suggest a 'specify an existing disk, dummy' error message.
Comment 1 David Lawrence 2006-10-20 17:13:56 EDT
*** Bug 211681 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lalancette 2008-03-11 21:50:10 EDT
On current RHEL-5, you get the following message if you try to start a guest
with a disk that doesn't exist:

[root@dhcp83-137 xen]# xm create rhel5test
Using config file "./rhel5test".
No handlers could be found for logger "xend"
Error: Disk isn't accessible
Usage: xm create <ConfigFile> [options] [vars]

Is that sufficient, or do you want more error logging?

Chris Lalancette
Comment 4 Tim Boyer 2008-03-11 22:54:11 EDT
That's sufficient, I think...
Comment 5 Chris Lalancette 2008-03-12 08:11:17 EDT
OK, excellent.  I'm pretty sure this has been in there for quite a while at this
point, so I'm going to close it out as CURRENTRELEASE.  If you find differently,
or run into similar problems, feel free to reopen.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.