Bug 211735 - Feature Request: error message distinction
Feature Request: error message distinction
Status: CLOSED DUPLICATE of bug 350701
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
:
: 211732 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-21 10:44 EDT by Chris Miller
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 06:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Miller 2006-10-21 10:44:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
There are two reasons why dependencies fail for rpm Install/Update and the error message shold distinguish between them.

1) This package requires other packages not currently present
2) Other packages require that this package remain

Impact: Resolving these two cases requires differrent procedure so distinct error messages would make processing the log easier.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
Determine where the dependency failed error message is produced and distinguish between the two cases.

Actual Results:


Expected Results:


Additional info:
Comment 1 Jeff Johnson 2006-10-22 08:03:39 EDT
I believe that rpm already distinguishes these 2 cases by inserting the string "... (installed) ..."
for what you are calling case 2).

Can you suplly specific examples of the text and/or the context where rpm does not distinguish
the two cases?
Comment 2 Chris Miller 2006-10-22 10:44:55 EDT
The two cases can already be distinguished as you point out, but the *error 
message* is the same in both cases.  Processing the log is more difficult when 
the error message must be qualified by the subsequent lines.  By the time I 
learn if I have case 1 or case 2, I have already had to decide which log to 
write.  My preference would be to capture the error message and decide if I 
have case 1 or case 2 and then write the subsequent qualifying lines to the 
appropriate log.

I'm pretty sure rpm knows why the dependency has failed at the time the error 
message is issued and before the list of offending items is produced.  There is 
no harm in letting the user in on the secret.

This does raise the interesting and previously unconsidered case 3 where both 
case 1 and case 2 apply...  I think that should also have it's own message.

This is not a bug and everything works correctly, so far as I know.  This 
feature would simply be an expedient for system administration when there are a 
lot of machines to manage.
Comment 3 Jeff Johnson 2006-10-22 12:01:55 EDT
Changing the error msgs to be more specific is as likely to be disruptive as
leaving bad enough alone. The necessary 1) and 2) cases are distinguished,
albeit perhaps less clearly than everyone would like.

I'm not sure I understand what you mean by "... the *error message* ..."
AFAIK, the error msgs are different, case 2) has "... (installed) ..." and I've
asked for specifics if that is not already true in rpmlib. If all you mean is
that the beginning "is needed by" is common in the 2 msgs, well, yah.

The problem is that error msgs are translated, and used in python exceptions,
and wired in python/shell/perl scripts, so its not just changing text in a fprintf
within rpmlib.

There is always a case 4) and a case 5) and a case 6) and ... because the universe of errors
is considerably larger than the universe of functionality. Basically, I don't see a
clear and postive gain in adding a separate, collapsed, case 3) error msg.
Comment 4 Matthew Miller 2007-04-06 12:37:54 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Panu Matilainen 2007-06-27 09:40:42 EDT
*** Bug 211732 has been marked as a duplicate of this bug. ***
Comment 6 Red Hat Bugzilla 2007-08-21 01:27:35 EDT
User pnasrat@redhat.com's account has been closed
Comment 7 Panu Matilainen 2007-08-22 02:31:49 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 8 Panu Matilainen 2007-10-25 06:54:29 EDT
Marking as dupe of bug 350701 - the message isn't very optimal to begin with but
the fact that it's impossible to translate to various languages can be
considered as a bug.

*** This bug has been marked as a duplicate of 350701 ***

Note You need to log in before you can comment on or make changes to this bug.