Bug 211742 - FATAL: Error inserting acpi_cpufreq
FATAL: Error inserting acpi_cpufreq
Status: CLOSED DUPLICATE of bug 212031
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-21 12:18 EDT by Heiko Adams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 11:19:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (16.59 KB, text/plain)
2006-10-21 12:18 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2006-10-21 12:18:28 EDT
Description of problem:
During init startup service at
"start service cpuspeed" I get the following error
"FATAL: Error inserting acpi_cpufreq ... no such file or directory"

When trying to start cpuspeed manually I get the following erro
"Error: Could not open file for writing:
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory"

Version-Release number of selected component (if applicable):
kernel 2.6.18-1.2200.fc5

How reproducible:
persistent


Steps to Reproduce:
1. Install latest kernel for fc5
2. Reboot the system
  
Actual results:
cpuspeed didn't start

Expected results:
cpuspeed is started

Additional info:
Processor is Intel Celeron M 1.5 GHz

see attached for dmesg output
Comment 1 Heiko Adams 2006-10-21 12:18:28 EDT
Created attachment 139057 [details]
dmesg output
Comment 2 Heiko Adams 2006-10-21 12:50:32 EDT
I'm sorry, the error message on system startup is "No such device" and not "No
such file or directory"
Comment 3 Liang Zhang 2006-10-23 23:42:33 EDT
This is not a bug about cpuspeed. If you use the other frequency scaling tools
(like cpudynd,  cpufreqd,  powernowd, and so on), it will also fail.
The reason which creates this bug is that the directory of
/sys/devices/system/cpu/cpu0/cpufreq doesn't exist.
You should re-compile your kernel enabling cpufreq support.
Comment 4 Heiko Adams 2006-10-24 14:12:52 EDT
Thanks for the info. I've made a clone of this bug for the kernel
Comment 5 Jarod Wilson 2006-12-21 11:19:52 EST
I believe this was just cpuspeed loading the wrong driver, should be fixed in
the latest update.

*** This bug has been marked as a duplicate of 212031 ***

Note You need to log in before you can comment on or make changes to this bug.