Bug 212031 - FATAL: Error inserting acpi_cpufreq
FATAL: Error inserting acpi_cpufreq
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jarod Wilson
: Regression
: 211742 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 14:09 EDT by Heiko Adams
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.2.1-1.46.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 11:27:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (16.59 KB, text/plain)
2006-10-24 14:09 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2006-10-24 14:09:59 EDT
+++ This bug was initially created as a clone of Bug #211742 +++

Description of problem:
During init startup service at
"start service cpuspeed" I get the following error
"FATAL: Error inserting acpi_cpufreq ... no such device"

When trying to start cpuspeed manually I get the following erro
"Error: Could not open file for writing:
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory"

Version-Release number of selected component (if applicable):
kernel 2.6.18-1.2200.fc5

How reproducible:
persistent


Steps to Reproduce:
1. Install latest kernel for fc5
2. Reboot the system
  
Actual results:
cpuspeed didn't start

Expected results:
cpuspeed is started

Additional info:
Processor is Intel Celeron M 1.5 GHz

see attached for dmesg output
Comment 1 Heiko Adams 2006-10-24 14:09:59 EDT
Created attachment 139248 [details]
dmesg output
Comment 2 Bastien Nocera 2006-10-24 18:47:34 EDT
I believe this is the same thing that keeps my Pentium M's CPU at full speed.
The ACPI governor worked since fc3 onwards on this machine, so it must be a
regression that the acpi-cpufreq driver won't load anymore.
Comment 3 Gen Zhang 2006-10-26 05:21:34 EDT
I found that the fc6test3 worked fine in this regard. My hardware is a core duo
mac mini.
Comment 4 Gen Zhang 2006-10-26 05:22:39 EDT
I meant to say that it's broken again in fc6.
Comment 5 Dave Jones 2006-11-12 00:55:18 EST
I've figured out the problem with this. It needs a change to the cpuspeed
initscript.  I'll get an update pushed out.
Comment 6 Jarod Wilson 2006-12-21 11:18:28 EST
Update pushed, please try the latest cpuspeed, should resolve the problem here...
Comment 7 Jarod Wilson 2006-12-21 11:20:15 EST
*** Bug 211742 has been marked as a duplicate of this bug. ***
Comment 8 Heiko Adams 2007-01-13 08:22:20 EST
Problem is still there on my machine.

Some more infos for you:

bash-3.1$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Celeron(R) M processor         1.50GHz
stepping        : 8
cpu MHz         : 1496.391
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss tm pbe up
bogomips        : 2994.46

bash-3.1$ rpm -qa|grep kernel
kernel-headers-2.6.18-1.2869.fc6
kernel-devel-2.6.18-1.2869.fc6
kernel-2.6.18-1.2869.fc6

bash-3.1$ rpm -qa|grep cpuspeed
cpuspeed-1.2.1-1.46.fc6

[root@Ostfriesland ~]# cpuspeed
Error: Could not open file for writing:
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory
Comment 9 Heiko Adams 2007-01-13 08:24:45 EST
Sorry, i forgot:

bash-3.1$ cat /etc/cpuspeed.conf 
# /etc/cpuspeed.conf
#
# This configuration file controls the behavior of both the
# cpuspeed daemon and various cpufreq modules.

### DRIVER ###
# Your CPUFreq driver module
# Note that many drivers are now built-in, rather than built as modules,
# so its usually best not to specify one. The most commonly-needed driver
# module these days is 'p4-clockmod', however, in most cases, it is not
# recommended for use. See: http://lkml.org/lkml/2006/2/25/84
# default value: empty (try to auto-detect/use built-in)
DRIVER=

### GOVERNOR ###
# Which scaling governor to use
# Details on scaling governors for your cpu(s) can be found in
# cpu-freq/governors.txt, part of the kernel-doc package
# NOTES:
# - The GOVERNOR parameter is only valid on centrino, powernow-k8 (amd64)
#   and p4-clockmod platforms, other platforms that support frequency
#   scaling always use the 'userspace' governor.
# - Using the 'userspace' governor will trigger the cpuspeed daemon to run,
#   which provides said user-space frequency scaling.
# default value: empty (defaults to ondemand on centrino, powernow-k8,
#                       and p4-clockmod systems, userspace on others)
GOVERNOR=

### FREQUENCIES ###
# NOTE: valid max/min frequencies for your cpu(s) can be found in
# /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_frequencies
# on systems that support frequency scaling (though only after the
# appropriate drivers have been loaded via the cpuspeed initscript).
# maximum speed to scale up to
# default value: empty (use cpu reported maximum)
MAX_SPEED=
# minimum speed to scale down to
# default value: empty (use cpu reported minimum)
MIN_SPEED=

### SCALING THRESHOLDS ###
# Busy percentage threshold over which to scale up to max frequency
# default value: empty (use governor default)
UP_THRESHOLD=
# Busy percentage threshold under which to scale frequency down
# default value: empty (use governor default)
DOWN_THRESHOLD=

### NICE PROCESS HANDLING ###
# Let background (nice) processes speed up the cpu
# default value: 0 (background process usage can speed up cpu)
# alternate value: 1 (background processes will be ignored)
IGNORE_NICE=0


#####################################################
########## HISTORICAL CPUSPEED CONFIG BITS ##########
#####################################################
VMAJOR=1
VMINOR=1

# Add your favorite options here
#OPTS="$OPTS -s 0 -i 10 -r"

# uncomment and modify this to check the state of the AC adapter
#OPTS="$OPTS -a /proc/acpi/ac_adapter/*/state"

# uncomment and modify this to check the system temperature
#OPTS="$OPTS -t /proc/acpi/thermal_zone/*/temperature 75"
Comment 10 Jarod Wilson 2007-01-15 12:05:36 EST
(In reply to comment #8)
> Problem is still there on my machine.
[...]
> [root@Ostfriesland ~]# cpuspeed
> Error: Could not open file for writing:
> /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
> Error: No such file or directory

Please try starting it up via the initscript, some of the prep work it does may
be required to get to the point where you have a
/sys/devices/system/cpu/cpu0/cpufreq/ directory and scaling_governor file to do
anything with.
Comment 11 Heiko Adams 2007-01-15 12:39:47 EST
I'm sorry, but im not so experienced with handling initscripts. How should I do it?
Comment 12 Jarod Wilson 2007-01-15 13:23:43 EST
As root, '/sbin/service cpuspeed start' will do the trick.
Comment 13 Heiko Adams 2007-01-15 13:36:05 EST
I did so and got the following:
[root@Ostfriesland ~]# /sbin/service cpuspeed start
[root@Ostfriesland ~]# /sbin/service cpuspeed status
cpuspeed wurde angehalten
Comment 14 Jarod Wilson 2007-01-15 13:47:40 EST
Based on that output, along with your original bug report, it looks like there
simply isn't any cpu frequency scaling support for your system -- different case
for Bastien and Gen, their systems ought to be working now.

You *might* get something that resembles cpu frequency scaling if you use the
p4-clockmod driver (set DRIVER=p4-clockmod in /etc/cpuspeed.conf), but according
to kernel folks who handle the cpu freq scaling code, its mostly worthless (see
reference url, also in /etc/cpuspeed.conf).
Comment 15 Bastien Nocera 2007-01-15 14:04:07 EST
(In reply to comment #14)
> Based on that output, along with your original bug report, it looks like there
> simply isn't any cpu frequency scaling support for your system -- different case
> for Bastien and Gen, their systems ought to be working now.
> 
> You *might* get something that resembles cpu frequency scaling if you use the
> p4-clockmod driver (set DRIVER=p4-clockmod in /etc/cpuspeed.conf), but according
> to kernel folks who handle the cpu freq scaling code, its mostly worthless (see
> reference url, also in /etc/cpuspeed.conf).

I hope that's not what you're hoping will be a resolution ;)
The machine I see that on is a Centrino-based laptop, and has had working
frequency scaling via ACPI since at least FC3. My guess is that the error
message is due to the kernel not having ACPI cpufreq handling, which is what I
mentioned in comment #2.
Comment 16 Jarod Wilson 2007-01-15 14:13:53 EST
(In reply to comment #15)
> > for Bastien and Gen, their systems ought to be working now.
[...]
> I hope that's not what you're hoping will be a resolution ;)
> The machine I see that on is a Centrino-based laptop, and has had working
> frequency scaling via ACPI since at least FC3. My guess is that the error
> message is due to the kernel not having ACPI cpufreq handling, which is what I
> mentioned in comment #2.

Hrm, no, I was of the belief that your system should have functional cpu
frequency scaling with the latest cpuspeed (see comment #5 and comment #6). I
take it that's not the case?
Comment 17 Heiko Adams 2007-01-15 15:00:49 EST
Maybe I'm wrong but IMHO a mobile celeron *should* have frequency scaling
Comment 18 Jarod Wilson 2007-01-15 15:49:41 EST
(In reply to comment #17)
> Maybe I'm wrong but IMHO a mobile celeron *should* have frequency scaling

One would think so, yes, and I did suggest a way you might get it. There's no
est in your cpu flags (from /proc/cpuinfo), so enhanced speedstep doesn't appear
to be supported on your system. After a another glance at your dmesg output, I
do see "ACPI: Processor [CPU0] (supports 8 throttling states)" though. This is
likely the older (non-enhanced) speedstep, which I think p4-clockmod knows how
to deal with, so again, you might try specifying that in your config file, with
the caveat that use of p4-clockmod isn't held in very high regard.
Comment 19 Heiko Adams 2007-01-15 15:58:14 EST
Thanks a lot. After adding p4-clockmod as driver to cpuspeed.conf I got the
following:

[root@Ostfriesland etc]# /sbin/service cpuspeed start
Enabling ondemand cpu frequency scaling:                   [  OK  ]
[root@Ostfriesland etc]# /sbin/service cpuspeed status
Frequency scaling enabled using ondemand governor

So at the moment cpuspeed seems to work (again)
Comment 20 Jarod Wilson 2007-01-15 16:06:14 EST
Okay, I was thinking that would probably be the case. I'll have to pick davej's
brain for some history on p4-clockmod and cpuspeed -- I wasn't aware cpuspeed
was previously working on your system, so this would indicate we changed
something in such a way as to not load up p4-clockmod by default anymore...

Bastien, if you're still getting no throttling or frequency scaling w/the latest
cpuspeed, perhaps you're in need of DRIVER=p4-clockmod in your cpuspeed config
as well?
Comment 21 Bastien Nocera 2007-01-16 04:38:21 EST
Turns out the i586 kernel was installed on this machine (certainly not by hand),
so I guess anaconda made a boo-boo. After installing the i686 kernel, I don't
have any problems anymore, and frequency scaling works. Thanks Jarod.
Comment 22 Jarod Wilson 2007-01-16 11:27:11 EST
(In reply to comment #21)
> Turns out the i586 kernel was installed on this machine (certainly not by hand),
> so I guess anaconda made a boo-boo. After installing the i686 kernel, I don't
> have any problems anymore, and frequency scaling works. Thanks Jarod.

Ah yes, bug 211941 strikes again, forgot to add mention of that one in this
bug... :)

On that note, I'll go ahead and close this bug out.

Note You need to log in before you can comment on or make changes to this bug.