Bug 2118062 - Please branch and build mingw-libgcrypt for EPEL 9
Summary: Please branch and build mingw-libgcrypt for EPEL 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mingw-libgcrypt
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2167575 (view as bug list)
Depends On: 2118067 2169180
Blocks: 2093596 2118061
TreeView+ depends on / blocked
 
Reported: 2022-08-13 21:15 UTC by Orion Poplawski
Modified: 2023-02-21 16:37 UTC (History)
7 users (show)

Fixed In Version: mingw-libgcrypt-1.8.4-6.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-21 16:37:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Orion Poplawski 2022-08-13 21:15:38 UTC
Please branch and build mingw-libgcrypt in epel9.

If you do not wish to maintain mingw-libgcrypt in epel9,
or do not think you will be able to do this in a timely manner,
the EPEL Packagers SIG would be happy to be a co-maintainer of the package;
please add the epel-packagers-sig group through
https://src.fedoraproject.org/rpms/mingw-libgcrypt/addgroup
and grant it commit access, or collaborator access on epel* branches.

I would also be happy to be a co-maintainer (FAS: orion).

We will require an ExclusiveArch until RHEL 9.1 when they should be shipping the mingw-gcc packages on all arches.

Scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=90769640

DEBUG util.py:443:  No matching package to install: 'mingw32-dlfcn'
DEBUG util.py:443:  No matching package to install: 'mingw32-libgpg-error'
DEBUG util.py:443:  No matching package to install: 'mingw64-dlfcn'
DEBUG util.py:443:  No matching package to install: 'mingw64-libgpg-error'

Comment 1 Ben Cotton 2023-02-07 14:53:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 2 Orion Poplawski 2023-02-11 05:11:25 UTC
Will you be able to branch and build mingw-libgcrypt in epel9?
The EPEL Packagers SIG would be happy to be a co-maintainer
if you do not wish to build it on epel9.

Comment 3 Richard W.M. Jones 2023-02-11 07:13:59 UTC
That should be done now.  We should really find a way to
make this process not depend on the Fedora packager.  I have
no objection to anyone who wants to create an EPEL branch.

Comment 4 Orion Poplawski 2023-02-12 14:56:45 UTC
Thank you.  At least now going forward the EPEL packaging SIG will be able to request new EPEL branches.

Comment 5 Orion Poplawski 2023-02-12 20:37:55 UTC
*** Bug 2167575 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2023-02-12 20:38:21 UTC
FEDORA-EPEL-2023-5efdea2259 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5efdea2259

Comment 7 Fedora Update System 2023-02-13 01:16:15 UTC
FEDORA-EPEL-2023-5efdea2259 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5efdea2259

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-02-21 16:37:17 UTC
FEDORA-EPEL-2023-5efdea2259 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.