Bug 2093596 - Please branch and build wine in epel9
Summary: Please branch and build wine in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel9
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2051065 2118057 2118058 2118060 2118062 2118063 2118065 2122234 2167574 2167575
Blocks: 2104325
TreeView+ depends on / blocked
 
Reported: 2022-06-04 15:33 UTC by tasmanian
Modified: 2023-02-24 04:12 UTC (History)
7 users (show)

Fixed In Version: wine-8.0-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-24 04:12:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description tasmanian 2022-06-04 15:33:27 UTC
Please branch and build wine in epel9.

Comment 1 David 2022-06-29 19:02:50 UTC
Yes, it is important for RHEL 9 to get this built.

Comment 2 tiberias 2022-08-12 21:54:24 UTC
I just got frustrated when I saw that wine is not in the repos. Is there a reason that it is not included in EPEL 9? It's understandable when things get pushed to the background or have only a small priority, but not finding any information at all is just frustrating.

Comment 3 Orion Poplawski 2022-08-13 21:24:38 UTC
Lots of missing deps:

DEBUG util.py:443:  No matching package to install: 'freeglut-devel'

DEBUG util.py:443:  No matching package to install: 'mingw32-lcms2'
DEBUG util.py:443:  No matching package to install: 'mingw32-libpng'
DEBUG util.py:443:  No matching package to install: 'mingw32-libxml2'
DEBUG util.py:443:  No matching package to install: 'mingw32-libxslt'
DEBUG util.py:443:  No matching package to install: 'mingw32-vkd3d'
DEBUG util.py:443:  No matching package to install: 'mingw32-vulkan-headers'
DEBUG util.py:443:  No matching package to install: 'mingw64-lcms2'
DEBUG util.py:443:  No matching package to install: 'mingw64-libpng'
DEBUG util.py:443:  No matching package to install: 'mingw64-libxml2'
DEBUG util.py:443:  No matching package to install: 'mingw64-libxslt'
DEBUG util.py:443:  No matching package to install: 'mingw64-vkd3d'
DEBUG util.py:443:  No matching package to install: 'mingw64-vulkan-headers'

Comment 4 David 2022-11-03 15:12:23 UTC
Hi, is there any update in this? It has been a very long time since RHEL 9 came out and still no Wine. Is somebody chasing people up on the missing dependencies? Thanks!

Comment 5 Orion Poplawski 2022-11-04 00:21:01 UTC
Did you check the blockers?  I am doing some chasing, but probably could use some help.  I've updated some pings.  We are also waiting for the release of RHEL 9.1 for some deps.

Comment 6 Orion Poplawski 2022-11-04 00:23:32 UTC
Also, just to set expectations, it generally takes a few point releases of RHEL before EPEL is close to parity with the previous release.

Comment 7 David 2023-01-04 15:08:04 UTC
Hi Orion, just a quick follow up on getting those dependencies built.

1. I see you took command on https://bugzilla.redhat.com/show_bug.cgi?id=2092177 , awesome! Are you OK to build it and follow up on https://bugzilla.redhat.com/show_bug.cgi?id=2118058 now?

2. I noted that Richard W.M. Jones was asking for your help to make progress on https://bugzilla.redhat.com/show_bug.cgi?id=2118060

Happy new year :)

Comment 8 Orion Poplawski 2023-01-05 02:38:36 UTC
Thanks for the ping.  I've built mingw-libtiff.  I have a PR to update lcms2 then will build for EPEL9.  I've requested the EPEL9 branch for mingw-libxml2.

Comment 9 Michael Cronenworth 2023-02-07 04:35:05 UTC
Orion, the following are remaining:

mingw-FAudio (I have this one)
mingw-SDL2 (required by FAudio)
mingw-libgcrypt (required by mingw-libxslt)
mingw-libgpg-error (required by mingw-libgcrypt)
mingw-dlfcn (required by mingw-libgcrypt)
mingw-gettext (required by mingw-libgpg-error)
mingw-win-iconv (required by mingw-libgpg-error)
mingw-termcap (required by mingw-gettext)

That should be the full dependency tree.

Comment 10 Michael Cronenworth 2023-02-15 15:27:51 UTC
SDL2-devel is not available to the koji builders. Required to build FAudio. @orion what should we do about that?

I could drop the requirement and stop building the Linux FAudio binaries for EPEL if Red Hat won't ship SDL2-devel to the koji builders, but I'd rather not.

Comment 11 Orion Poplawski 2023-02-15 22:27:54 UTC
Looks like a buildroot override was submitted: https://bodhi.fedoraproject.org/overrides/mingw-SDL2-2.26.2-1.el9 so should be available now.  I had not gotten around to submitting an update, which I've done now.  Finally, looks like the package only provides mingw*-SDL2-static.  Is that typical for mingw packages?

Comment 12 Michael Cronenworth 2023-02-16 02:03:32 UTC
Yes, I made that build override.

However, the issue is specifically with 'SDL2-devel', the native package, and not the mingw-SDL2 package. The FAudio package originally built Linux ELF binaries and only recently started building both ELF and PE binaries. Fedora is switching to merge mingw-* packages into their native counterparts. FAudio is one of those.

I'm not sure what you mean about it only providing a -static package. It provides both non-static and static packages.

Comment 13 Orion Poplawski 2023-02-16 02:21:25 UTC
Ah, I see. EL9 currently has SDL2-devel 2.0.20, Stream 9 has 2.26.0.  So you can build now for epel9-next.  epel9 will need to wait for the next EL9 release.

Comment 14 Michael Cronenworth 2023-02-16 02:43:10 UTC
Ah... Do you know when that would be? If it's months out I may temporarily drop the ELF packages from EPEL9.

Comment 15 Orion Poplawski 2023-02-16 02:57:20 UTC
Should be in May: https://access.redhat.com/articles/3078

Comment 16 Fedora Update System 2023-02-16 06:55:26 UTC
FEDORA-EPEL-2023-65253d97b8 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-65253d97b8

Comment 17 Michael Cronenworth 2023-02-16 07:00:43 UTC
Caveats:
1. FAudio is PE only due to SDL2 version
2. Hacked configure in mingw-libxslt for automake version
3. Wine for 64-bit ARM fails at the moment. I have not debugged why.

Comment 18 Orion Poplawski 2023-02-16 13:49:23 UTC
aarch64:

winebuild: cannot find the 'dlltool' tool

Hmm, probably something missing in the RHEL9 packages?

Comment 19 Michael Cronenworth 2023-02-16 13:54:51 UTC
Yes, possibly. I haven't studied the output and would probably need access to a config.log or other detail to see why.

For others to reference:
- EPEL9 aarch64: https://kojipkgs.fedoraproject.org//work/tasks/8654/97558654/build.log
- Fedora 38 aarch64: https://kojipkgs.fedoraproject.org//packages/wine/8.0/1.fc38/data/logs/aarch64/build.log

Comment 20 Fedora Update System 2023-02-17 02:22:37 UTC
FEDORA-EPEL-2023-65253d97b8 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-65253d97b8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2023-02-24 04:12:13 UTC
FEDORA-EPEL-2023-65253d97b8 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.