Bug 211896 - No handlers error during install
No handlers error during install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
: 212575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-23 14:53 EDT by Chris Ricker
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:33:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2006-10-23 14:53:25 EDT
Installing FC6 from DVD in text mode

During the Dependency Check, the message

No handlers could be found for logger "yum.YumBase"

appears on the screen
Comment 1 Dax Kelson 2006-10-24 13:03:23 EDT
I tried to reproduce this inside a VMware instance and was unable. I tried using
the DVD in text mode and just using the defaults for all the screens. I tried do
a custom package selection. I didn't see the error.
Comment 2 Jussi Torhonen 2006-10-25 14:27:40 EDT
I got this. Trying to upgrade FC5 to FC6. GUI install hangs when checking
dependencies. No errormsg seen. Text mode installer hangs in dependency checking
saying that:

No handlers could be found for logger "yum.YumBase"

Please trace this and give us some workaround to upgrade.

I have AMD Athlon 1300 MHz, 1 GB RAM, 2 x IBM IDE 60 GB configured as software
RAID1 mirror set. Booting installer from ATAPI CD-ROM drive with install CD #1 of 5.
Comment 3 Jussi Torhonen 2006-10-26 00:19:04 EDT
See

http://forums.fedoraforum.org/showthread.php?p=634492#post634492

Actually saw some ERROR or WARNING about /var/lib/rpm/__db* files in some
virtual console when installer hanged. My current FC5 installation has those
files there on the hdd. So, is it widely recommended to

rm -f /var/lib/rpm/__db*

rpm --rebuilddb

..before upgrading? Is there any problems comening if doing that task before
giving the upgrade a new try?

My FC5 is fully patched. Yum and standalone rpm works fine there. I know there's
been those problems in rpm which sometimes requires you to 'rpm --rebuilddb'
manually, but I believe that the rpm of FC5 would be fixed for this already. I
guess RH8 and RH9 had these problems with old rpm versions.
Comment 4 Jackie 2006-10-26 21:55:37 EDT
Tried rm -f /var/lib/rpm/__db* and rpm --rebuilddb and it still hung up. I am
going to let it sit for about an hour and see what happens.
Comment 5 Jackie 2006-10-26 22:26:49 EDT
(In reply to comment #4)
> Tried rm -f /var/lib/rpm/__db* and rpm --rebuilddb and it still hung up. I am
> going to let it sit for about an hour and see what happens.

I let it sit for about 45 minutes and the update continued as normal. 
Comment 6 Jussi Torhonen 2006-10-27 07:33:32 EDT
Same here. It took more than 30 minutes to check the dependencies. After that
the upgrade succeeded, even the total time spent was longer than ever. After any
CD change there was a bit shorter wait time.
Comment 7 Răzvan Sandu 2006-11-02 20:11:42 EST
*** Bug 212575 has been marked as a duplicate of this bug. ***
Comment 8 Răzvan Sandu 2007-07-12 14:34:46 EDT
This seems to be fixed in Fedora 7 - should we closed it as NEXTRELEASE ?

Răzvan

Comment 9 Red Hat Bugzilla 2007-08-21 01:27:41 EDT
User pnasrat@redhat.com's account has been closed
Comment 10 Bug Zapper 2008-04-04 00:04:28 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Răzvan Sandu 2008-04-04 04:11:41 EDT
Hello,

As said in comments #8 and #9, this was fixed in Fedora 7. IMHO, this bug may be
closed.

I would close it, but I'm not an authorised user.

Răzvan

Note You need to log in before you can comment on or make changes to this bug.