Bug 211921 - Paravirt console missing after migrating a guest
Paravirt console missing after migrating a guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
: 229016 (view as bug list)
Depends On: 211911 212662
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-23 17:07 EDT by Daniel Berrange
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:38:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-10-23 17:07:00 EDT
Description of problem:
When migrating a guest across hosts, the paravirt vnc console does not get
activated on the destination. The VNC feature does not appear set on the
destination xend data, the VNC daemon is not started, and the vnc port is not
present in xenstored

Version-Release number of selected component (if applicable):
xen-3.0.3-2.el5

How reproducible:
Always

Steps to Reproduce:
1. Find a paravirt guest running the VNC console
2. Verify the VNC console is active & working
3. Migrate the guest to an alternate host
4. Try and connect to the VNC console
  
Actual results:
No VNC server is available for the migrated guest

Expected results:
VNC server is available on the destination host

Additional info:
Very likely a similar root cause to bug 211911 (VNC missing after
suspend/restore cycle).
Comment 1 RHEL Product and Program Management 2006-10-26 15:01:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Daniel Berrange 2006-10-26 17:11:33 EDT
The migration codepath does indeed go through the same path as restore, so
fixing the restore problem, should fix VNC for migration too.
Comment 3 Daniel Berrange 2006-12-19 13:32:17 EST
This should now be operating correctly, as a result of the PVFB upgrade tracked
by bug 218050.
Comment 4 RHEL Product and Program Management 2006-12-22 20:38:05 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.
Comment 5 Daniel Berrange 2007-02-22 14:40:38 EST
*** Bug 229016 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.