This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 21197 - kickstart install fails on alpha cpu system
kickstart install fails on alpha cpu system
Status: CLOSED DUPLICATE of bug 19384
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 14:54 EST by harry.heinisch
Modified: 2015-01-07 18:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 13:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2000-11-21 14:54:06 EST
Kick start fails on lastest Alpha 7.0 image (worked on previous 7.0 beta)
target disk has 3 partitions hda1(swap) hda2(ext2) hda3(ext2)
Alpha DS10  (alpha  cpu)

######### captured from install dump

--Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/textw/partitioning_text.py", line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in 
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 120484760>
self: <lilo.LiloConfiguration instance at 12044c6b0>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


----- ks.cfg being run ----
# Kick Start for Alpha Servers
# jj 20-Nov-2000
#
#### Select a language
lang en_US
#### Install from cd-rom
cdrom
#### Keyboard to use
keyboard us
#### Use the partitions created by the Alpha Jump-start CD
partition /boot --onpart hda2
partition /  --onpart hda3
#### Install is the default but..
install
#### mouse type
mouse --emulthree genericps/2 
#### timezone selection
timezone US/Eastern
#### start of with xconfig
skipx
#xconfig --server "3DLabs" --monitor "Generic06"
#### Set root password
rootpw Compaq
#### Setup secirity autorization
auth --useshadow --enablemd5
#### Packages to install
%packages
@ Server
#@ GNOME
#@ KDE
#### Post install cleanup
%post --nochroot
# add comment to /etc/motd
echo "Kickstart-installed Red Hat Linux `/bin/date`" > /etc/motd
Comment 1 Michael Fulbright 2000-11-21 15:43:28 EST
This is a dupe of bug 19384.  Thank you for the test case, it will help us
diagnose this issue.

Assigning to a QA engineer to test.
Comment 2 Michael Fulbright 2001-04-02 11:42:01 EDT

*** This bug has been marked as a duplicate of 19384 ***

Note You need to log in before you can comment on or make changes to this bug.