Bug 19384 - Anaconda crashes with Kickstart installation
Anaconda crashes with Kickstart installation
Status: CLOSED DUPLICATE of bug 18648
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
: 21197 21562 22364 23431 23433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 11:55 EDT by Jay Liang
Modified: 2007-03-26 23:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 20:44:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Liang 2000-10-19 11:55:21 EDT
Anaconda crashes while I tried to install Linux with kickstart.  I created 
ks.cfg on the boot floppy and start the installation using "linux
ks=floppy" command.  After the boot up, I selected local CD-ROM as the
source and soon after anaconda started, it crashed.

Below is the content of anacdump.txt:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/partitioning_text.py",
line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 824b7d0>
self: <lilo.LiloConfiguration instance at 82498e8>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-19 17:58:41 EDT
Please attach the kickstart file you are using.

Most certainly a duplicate of bug 18648.
Comment 2 Jay Liang 2000-10-19 18:11:47 EDT
Here is the ks.cfg I was using:

lang en_US

network --bootproto dhcp

cdrom

device ethernet 3c59x

keyboard "us"

zerombr yes
clearpart --linux
part swap --size 267
install

mouse genericps/2 --emulthree

timezone America/Chicago

xconfig --server "Mach64" --monitor "generic monitor"

rootpw --iscrypted $1$90.qXmx3$Yau0H7Re1FP/BXijucaOp.

auth --nisdomain spc.noaa.gov --useshadow

lilo --location mbr

%packages
chkconfig
sed
psmisc
XFree86-libs
glib
openssl
amanda-server
apache-manual
aspell-cs
audiofile-devel
bdflush
bzip2
cleanfeed
cpio
desktop-backgrounds
dip
ElectricFence
expect
fortune-mod
gd
gettext
kernel-headers
gnome-games
gnome-pim
gnotepad+
groff
gv
imlib-devel
iproute
jadetex
kdenetwork
kernel-source
kudzu-devel
libjpeg
libtiff
lilo
ltrace
mars-nwe
mkbootdisk
mouseconfig
ncompress
netpbm-progs
ntsysv
openssl-devel
pilot-link
portmap
pspell
pythonlib
rdate
rhn_register
rpm-build
rwall-server
sawfish
setuptool
smpeg
SVGATextMode
tcl
tetex-afm
time
tmpwatch
up2date-gnome
WindowMaker
xboard
XFree86-FBDev
XFree86-ISO8859-7-Type1-fonts
XFree86-tools
xinitrc
xpat2
xtrojka
aspell-es
auth_ldap
cipe
dhcp
enscript
freetype-utils
gcc-java
glib-gtkbeta
gnome-print-devel
guile-devel
jed
kdeadmin
krb5-server
libgcj-devel
librep-devel
locale_config
man-pages-da
mawk
mod_php
nasm-doc
nut-cgi
openssl-pythonpinfo
procinfo
pygnome-applet
python-tools
rhclib
rwall
sox-devel
taper
ucd-snmp-devel
vim-X11
wget
xemacs-el
xsane-gimp
basesystem
libtermcap
e2fsprogs
modutils
cracklib
chkfontpath
readline
anacron
ash
aspell-devel
autoconf
bind-utils
cdda2wav
compat-libstdc++
crontabs
dhcpcd
dosfstools
emacs-nox
file
ftp
gdbm-devel
ghostscript-fonts
gnome-applets
gnome-libs-devel
libxml
gnupg
gtk+-devel
ical
inews
ipxutils
kdegames
kdetoys
kernel-enterprise
krb5-devel
libglade-devel
libstdc++
libungif
LPRng
MAKEDEV
metamail
mod_ssl
multimedia
netcfg
nfs-utils
openssh-askpass-gnome
pciutils
plugger
printtool
pygtk-libglade
quota
rep-gtk
rp-pppoe
rsync
samba-common
SDL_image-devel
slang-devel
strace
talk
telnet
tetex-xdvi
tk
ucd-snmp-utils
vim-common
Xaw3d
XFree86-100dpi-fonts
XFree86-ISO8859-2-75dpi-fonts
XFree86-ISO8859-9-75dpi-fonts
XFree86-xdm
xloadimage
xpuzzles
ypbind
aspell-nl
bind-devel
comsat
e2fsprogs-devel
fetchmailconf
ftpcopy
getty_ps
glibc-profile
groff-gxditview
imap-devel
jikes
kdoc
krbafs-utils
libodbc++
libunicode-devel
lout
man-pages-fr
mgetty-sendfax
mtx
netscape-navigator
open
pam_krb5
php-imap
postgresql-odbc
pspell-devel
rgrep
rpmdb-redhat
sliplogin
sysctlconfig
transfig
usbview
w3c-libwww
xcpustate
xmms-devel
filesystem
db2termcap
info
gawk
logrotate
vixie-cron
grep
XFree86-xfs
pwdb
SysVinit
am-utils
gmp
xinetd
anaconda-runtime
apache
arpwatch
aspell
aspell-de
at
authconfig
awesfx
bind
bug-buddy
caching-nameserver
cdparanoia
compat-egcs-c++
control-center-devel
cproto
cyrus-sasl
dev86
diffstat
docbook
ee
emacs
esound-devel
fetchmail
finger-server
freetype
gcc-g77
gdb
gdm
ghostscript
glade
gmc
gnome-core
gnome-libs
gnome-objc
urw-fonts
gnome-utils
gnumeric
gpm-devel
gtk+
umb-scheme
hdparm
imlib
indexhtml
Inti-devel
iputils
isdn-config
kdebasekdesupport-devel
kernel
kernel-ibcs
kernelcfg
krb5-libs
libghttp
libgtop
libpng
libstdc++-devel
m4
libungif-devel
linuxconf
lrzsz
magicdev
man
memprof
mikmod
mkisofs
modemtool
mpg123
mutt
ncurses-devel
netpbm
netscape-communicator
njamd
openldap
openssh-clients
ORBit-devel
pciutils-devel
pine
pmake
postgresql-devel
procmail
pygnome
python-devel
qt-devel
raidtools
readline-devel
rep-gtk-gnome
rhs-printfilters
rp3
rpm-python
rusers
rxvt
sane
SDL
sendmail
shapecfg
slocate
sox
stunnel
switchdesk-gnome
talk-server
tcp_wrappers
telnet-server
tetex-dvips
texinfo
timetool
tkinterunzip
usermode
vim-minimal
wireless-tools
Xaw3d-devel
xcdroast
XFree86
XFree86-devel
XFree86-ISO8859-2-100dpi-fonts
XFree86-ISO8859-7-100dpi-fonts
XFree86-ISO8859-9-100dpi-fonts
XFree86-KOI8-R-75dpi-fonts
XFree86-V4L
XFree86-Xvfb
xjewel
xmorph
xpilot
xscreensaver
yp-tools
zlib-devel
aspell-it
aspell-sv
bash-doc
cdparanoia-devel
compat-egcs-objc
db3-devel
dump-static
emacs-leim
fbset
fnlib-devel
fribidi-gtkbeta-devel
gated
genromfs
gimp-perl
glib10
gnome-kerberos
gperf
gtk+-gtkbeta-devel
imap
isicom
jed-xjed
kaffe
kdebase-lowcolor-icons
kpackage
krbafs
libelf
libjpeg6a
libpcap
libunicode
lm_sensors
lockdev-devel
macutils
man-pages-es
man-pages-pl
mgetty
mkkickstart
mtr-gtk
mysql-serveroctave
openldap-servers
p2c-devel
parted
php
php-mysql
postgresql-jdbc
postgresql-tcl
psacct
pvm-gui
qt1x-GL
rhcfile
rhmask
rpmfind
sawfish-themer
slrn-pull
squid
syslinux
tetex-doc
tree
units
uucp
vnc
w3c-libwww-apps
wmconfig
xdaliclock
xfig
xmms-gnome
xtoolwait
setup
db1
mktemp
ncurses
mingetty
popt
which
initscripts
zlib
cracklib-dicts
pam
adjtimex
gdbm
python
anaconda
mailcap
apmd
asp2php-gtk
aspell-da
aspell-en-gb
aumix
autorun
perl
bison
bzip2-devel
cdp
compat-egcs
control-center
cpp
cvs
dev
dialog
sgml-common
ed
elm
esound
extace
finger
freeciv
gcc-c++
gd-devel
gdk-pixbuf-devel
gftp
gimp-devel
glibc-devel
gnome-audio-extra
gnome-games-devel
gnome-media
gnome-pim-devel
gnome-users-guide
gnuchess
gpm
groff-perl
gtop
gzip
ImageMagick-devel
indent
Inti
iptables
isapnptools
kbdconfig
kdelibs
kdesupport
kdevelop
kernel-pcmcia-cs
kgcc
kudzu
libghttp-devel
libgtop-devel
libpng-devel
libtermcap-devel
libtool
libxml-devel
linuxconf-devel
lsof
mailx
man-pages
Mesa
minicom
mkxauth
mount
mt-st
ncftp
ncurses4
netpbm-devel
newt
nmh
openssh
openssh-server
passwd
pidentd
playmidi
pnm2ppa
postgresql-server
psgml
pygnome-libglade
python-xmlrpc
qt1x
rcs
redhat-logos
rep-gtk-libglade
rmt
rpm
rsh
rusers-server
samba
sash
SDL-devel
setserial
sharutils
slrn
stat
stylesheets
switchdesk-kde
tar
tcpdump
tetex
tetex-fonts
tftp-server
tin
tksysv
trojka
up2date
utempter
whois
wu-ftpd
xbill
xchat
XFree86-cyrillic-fonts
XFree86-ISO8859-2
XFree86-ISO8859-7
XFree86-ISO8859-9
XFree86-KOI8-R-100dpi-fonts
XFree86-twm
XFree86-Xnest
xisdnload
xmms
xpdf
xsane
xxgdb
zip
aspell-fr
aspell-pl
autofs
bootparamd
compat-egcs-g77
db2-devel
doxygen
emacs-el
ext2ed
fnlib
fribidi-gtkbeta
fvwm2-icons
gd-progs
gimp-data-extras
glib-gtkbeta-devel
gmp-devel
gnuplot
gtk+-gtkbeta
im
ircii
jed-common
joystick
kdebase-3d-screensavers
korganizer
krb5-workstation
lam
libgtop-examples
libodbc++-qt
libungif-progs
licq
lockdev
lslk
man-pages-de
man-pages-ja
mcserv
mgetty-voice
mtr
mysql-devel
nasm-rdoff
nss_ldap
nut-client
openldap-devel
p2c
pango-gtkbeta-devel
pdksh
php-manual
pmake-customs
postgresql-python
procps-X11
pvm
pygnome-capplet
python-docs
rarpd
rhcfile-devel
routed
rpmlint
sendmail-cf
smpeg-devel
sudo
sysreport
tftp
tripwire
unixODBC
vim-enhanced
vnc-doc
w3c-libwww-devel
x3270
xemacs
xlispstat
xosview
ytalk
glibc
bash
procps
shadow-utils
words
abiword
sh-utils
anonftp
asp2php
aspell-en-ca
automake
binutils
cdecl
console-tools
ctags
dia
dump
emacs-X11
findutils
gcc
gdk-pixbuf
gimp
gnome-audio
gnome-linuxconf
gnome-print
gphoto
gtk-engines
ImageMagick
inn
irda-utils
kdegraphics
kdeutils
kpppload
libglade
librep
libtool-libs
losetup
make
Mesa-devel
mod_perl
mtools
net-tools
newt-devel
openssh-askpass
patch
playmidi-X11
ppp
pygtk
qt1x-devel
redhat-release
rootfiles
rsh-server
samba-client
SDL_image
slang
statserial
sysstat
tcsh
tetex-latex
tix
ucd-snmp
util-linux
wvdial
Xconfigurator
XFree86-75dpi-fonts
XFree86-ISO8859-2-Type1-fonts
XFree86-KOI8-R
XFree86-xf86cfg
xmailbox
xrn
ypserv
aspell-no
blt
cxhextris
efax
firewall-config
fvwm2
giftrans
glms
gsl
inn-devel
joe
kdpms
kterm
libodbc++-devel
libxml10
lout-doc
man-pages-it
mgetty-viewfax
mysql
nscd
openldap-clients
pango-gtkbeta
php-ldap
postgresql-perl
pump-devel
readline2.2.1
rpm2html
sendmail-doc
symlinks
timed
unixODBC-devel
vnc-server
xbl
xlockmore
zsh
compat-glibc
fileutils
sysklogd
textutils
db3
amanda
amanda-client
apache-devel
aspell-ca
audiofile
bc
byacccontrol-panel
db1-devel
diffutils
eject
exmh
flex
gcc-objc
gedit
glib-devel
gnome-core-devel
gnome-objc-devel
gnorpm
gqview
guile
imlib-cfgeditor
ipchains
isdn4k-utils
kdemultimedia
kernel-doc
kernel-utils
less
libjpeg-devel
libtiff-devel
links
lynx
mc
mkinitrd
mpage
ncpfs
netscape-common
openjade
ORBit
pilot-link-devel
postgresql
pump
qt
rdist
rhn_register-gnome
rpm-devel
rwho
screen
sgml-tools
sndconfig
switchdesk
tclx
tetex-dvilj
timeconfig
traceroute
urlview
WindowMaker-libs
xboing
XFree86-doc
XFree86-ISO8859-7-75dpi-fonts
XFree86-Mach64
xgammon
xpaint
xsriqt
rdist
rhn_register-gnome
rpm-devel
rwho
screen
sgml-tools
sndconfig
switchdesk
tclx
tetex-dvilj
timeconfig
traceroute
urlview
WindowMaker-libs
xboing
XFree86-doc
XFree86-ISO8859-7-75dpi-fonts
XFree86-Mach64
xgammon
xpaint
xsri
aspell-eo
aumix-X11
cdrecord-devel
db3-utils
enlightenment
freetype-devel
gcc-chill
gkermit
gnome-lokkit
gtk+10
itcl
kapm
kpilot
libgcj
libPropList
lm_sensors-devel
man-pages-cs
man-pages-ru
mod_dav
nasm
nut
openssl-perl
parted-devel
php-pgsql
postgresql-tk
pxe
qt-Xt
rhclib-devel
sane-devel
specspo
tcllib
unarj
vlock
wmakerconf
xemacs-info
xsysinfo

%post

aspell-eo
aumix-X11
cdrecord-devel

cdrecord

nc
ntp

trn

kdelibs-devel


pax
Comment 3 Brock Organ 2000-11-07 11:06:48 EST
did your ks file list get corrupted above? I noticed it has packages listed
AFTER the %post section ... Is that what you intended ...?

%post
aspell-eo
aumix-X11
cdrecord-devel
cdrecord
nc
ntp
trn
kdelibs-devel
pax
Comment 4 Brock Organ 2000-11-07 11:08:31 EST
also, I noticed you did not fully specify partitioning information in your ks
file above:

clearpart --linux
part swap --size 267
install

Did kickstart ask you interactively for partitioning information ...? What did
you finally end up with ...?
Comment 5 Jay Liang 2000-11-07 11:41:51 EST
1) The actual ks.cfg file I used ends with %post.  The extra stuff in the bug
report was from cut-and-paste.  Sorry about the confusion.
2) ks did not ask for interactive partitioning information.  I used the boot
floppy with ks.cfg on it.  I then used "linux ks=floppy" to boot.  Once booted,
I chose to load from the CD-ROM.  At this time, anaconda started for a few
seconds then crashed.
Comment 6 Michael Fulbright 2000-11-17 11:42:16 EST
Passing to QA to attempt to reproduce.
Comment 7 Michael Fulbright 2000-12-18 12:23:45 EST
*** Bug 22364 has been marked as a duplicate of this bug. ***
Comment 8 Brock Organ 2001-01-09 15:29:46 EST
*** Bug 21562 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2001-01-09 16:37:00 EST
*** Bug 23433 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2001-01-09 16:37:57 EST
*** Bug 23431 has been marked as a duplicate of this bug. ***
Comment 11 Brock Organ 2001-01-11 11:31:37 EST

*** This bug has been marked as a duplicate of 18648 ***
Comment 12 vcrump 2001-01-19 20:44:13 EST
I also experienced this problem (#23433), but now have it working.  The
mkkickstart adds the clearpart and part swap lines, but no other part lines. 
Apparently at least one part line is needed.  I wanted to do a kickstart @Server
installation, so I did it manually first, and then copied the partition table
info into part lines in my ks.cfg.  Now it works.
Comment 13 Michael Fulbright 2001-04-02 11:41:56 EDT
*** Bug 21197 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.