Bug 212145 - koffice: No pdf library dependency
Summary: koffice: No pdf library dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 158941
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-25 10:57 UTC by Andy Shevchenko
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 12:00:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Shevchenko 2006-10-25 10:57:24 UTC
Description of problem:
When I try to rebuild koffice with poppler (I think so due to koffice's 
makefile has $(POPPLER) variable for libkritapdfimport) installed I've got the 
message like following:

error: Installed (but unpackaged) file(s) found:
   /usr/lib/kde3/libkritapdfimport.la
   /usr/lib/kde3/libkritapdfimport.so
    Installed (but unpackaged) file(s) found:
   /usr/lib/kde3/libkritapdfimport.la
   /usr/lib/kde3/libkritapdfimport.so

Version-Release number of selected component (if applicable):
1.6.0-1 from FE5

Additional info:
Suggest to add BuildRequires: poppler-devel

Comment 1 Andreas Bierfert 2006-11-04 12:58:42 UTC
Actually the qt bindings are missing from the original poppler package thus this
won't work till #158941 is fixed. :(

Comment 2 Rex Dieter 2006-12-09 17:45:21 UTC
good news, 

%changelog
* Sat Dec 09 2006 Rex Dieter <rexdieter[AT]users.sf.net>
1.6.2-2
- BR: poppler-qt-devel (#158941,#212145)

As soon as poppler-qt becomes available (for FC-5/FC-6) we'll push updates 
there too.

Comment 3 Rex Dieter 2006-12-15 13:45:03 UTC
FC-6 update queue'd, FC-5 still waiting on popper-qt update (currently in
updates-testing)

Comment 4 Rex Dieter 2007-01-26 13:19:45 UTC
FC-5 build queued.

Comment 5 Rex Dieter 2007-01-26 13:44:42 UTC
Hmm, poppler-qt doesn't seem to be available (yet) for FC-5.  pinging poppler
maintainer (bug #158941)

Comment 6 Rex Dieter 2007-04-25 12:00:27 UTC
Finally!

* Wed Apr 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org>
1.6.2-3.1
- FC-5: +BR: poppler-qt-devel (#158941,#212145)



Note You need to log in before you can comment on or make changes to this bug.