This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 158941 - Poppler doesn't include the Qt binding
Poppler doesn't include the Qt binding
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: FutureFeature, Reopened
: 178442 183924 (view as bug list)
Depends On:
Blocks: 212145
  Show dependency treegraph
 
Reported: 2005-05-26 19:48 EDT by Andreas Simon
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 11:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
won't compile without this patch (900 bytes, patch)
2005-06-03 14:12 EDT, Neal Becker
no flags Details | Diff
specfile patch to enable -qt subpkg (option 1) (3.52 KB, patch)
2006-12-08 09:08 EST, Rex Dieter
no flags Details | Diff
specfile patch to enable -qt/-qt-devel subpkgs (option 2) (3.95 KB, patch)
2006-12-08 10:19 EST, Rex Dieter
no flags Details | Diff
specfile patch to enable -qt/-qt-devel subpkgs (option 2) (4.00 KB, patch)
2006-12-08 10:26 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Andreas Simon 2005-05-26 19:48:35 EDT
Poppler comes with a Qt binding but Fedora's rpm doesn't include this library.

Although currently there seems to be no packages in Fedora Core which could use
libpoppler-qt.so, it could be convenient for third-party packages or developers.
(the kfile plugin from KDE svn trunk already uses poppler's qt binding, and in
future it is planed to port kpdf to poppler-qt too).

The binding is part of the poppler-0.3.2.tar.gz and will be build automatically
if it isn't disabled via configure --disable-poppler-qt and qt-devel is installed.

There was a bug in poppler where the compilation of poppler-qt failed but this
is fixed since version 0.3.1.


Version-Release number of selected component (if applicable):
poppler-0.3.2-1
Comment 1 Neal Becker 2005-06-03 14:12:30 EDT
Created attachment 115133 [details]
won't compile without this patch
Comment 2 Rahul Sundaram 2005-08-13 16:52:49 EDT
Setting priority to high since patch is included
Comment 3 Kristian Høgsberg 2006-09-13 17:04:47 EDT
*** Bug 178442 has been marked as a duplicate of this bug. ***
Comment 4 Kristian Høgsberg 2006-09-13 17:05:06 EDT
*** Bug 183924 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Bierfert 2006-11-04 08:00:12 EST
Could this please be upgraded to include the qt bindings (at least for fc5,6 and
devel). Koffice depends on it.
Comment 6 Rex Dieter 2006-12-06 09:55:40 EST
Kristian,
If you're hesitant to enable the qt bindings, would you mind if someone (say me?
(: ) created poppler-qt/poppler-qt4 packages for Extras?
Comment 7 Sammy 2006-12-06 10:39:35 EST
It seems like having the --no-splash at the configure line is turning off
the qt-bindings. I have removed this and got the bindings in. I don't see
any splash with applications I use, so I am not sure whether this is neccessary
or not.

I need this primarily because kpdf depends on it.
Comment 8 Matthias Clasen 2006-12-06 14:59:09 EST
I talked to Kristian, and there is no reluctance to add a poppler-gt subpackage.
We just haven't gotten around to it. It will happen in time for FC7.
Comment 9 Rex Dieter 2006-12-06 15:04:34 EST
OK, duh, I totally overlooked that adding this probably wouldn't be a
possibility for anything pre-FC7.  Okie-dokie, I'll go ahead with the
poppler-qt/qt4 -> Extras (for FC-5/FC-6) plan (since clearly, nothing in Core
uses these).
Comment 10 Rex Dieter 2006-12-07 09:17:47 EST
Matthias or Kristian, quick question: I've got a poppler-extras package ready
for Extras (see bug #218768), and it seems to work(1), but in order to build the
qt/qt4 wrappers, the splash backend needs to be enabled.  Will there be problems
mixing these wrappers against a (core) poppler package built with
--disable-splash-output?  Further, I've included
%{_libdir}/pkgconfig/poppler-splash.pc
there too, which may or may not be needed or desirable.  Opinions?

(1) I tested building kdegraphics and trying kpdf
Comment 11 Matthias Clasen 2006-12-07 17:45:29 EST
I don't know if this will cause problems. But I don't see that adding a new
subpackage in FC6 (or even FC5) would be the end of the world, either.

Do you happen to have a specfile patch that adds a poppler-qt subpackage ?
Comment 12 Rex Dieter 2006-12-08 08:07:43 EST
> Do you happen to have a specfile patch that adds a poppler-qt subpackage?

I can whip up a specfile patch in a few minutes.  Thanks!

Comment 13 Rex Dieter 2006-12-08 08:25:25 EST
2 options:
1.  make -qt subpkg, include its devel bits in main -devel pkg.  Main -devel pkg
will now Requires: qt-devel
2.  make both -qt and -qt-devel subpkgs.

I'll go with implementing option 1 (for now).
Comment 14 Rex Dieter 2006-12-08 09:08:42 EST
Created attachment 143148 [details]
specfile patch to enable -qt subpkg (option 1)
Comment 15 Matthias Clasen 2006-12-08 09:52:20 EST
I think we'd prefer a separate qt-devel.
Comment 16 Rex Dieter 2006-12-08 09:54:00 EST
OK, option 2 patch coming up.
Comment 17 Rex Dieter 2006-12-08 10:19:06 EST
Created attachment 143154 [details]
specfile patch to enable -qt/-qt-devel subpkgs (option 2)
Comment 18 Rex Dieter 2006-12-08 10:22:55 EST
oops, that one wasn't quite right (it includes the qt headers in both -devel and
-qt-devel)... better one coming...
Comment 19 Rex Dieter 2006-12-08 10:26:56 EST
Created attachment 143155 [details]
specfile patch to enable -qt/-qt-devel subpkgs (option 2)
Comment 20 Matthias Clasen 2006-12-08 23:21:39 EST
Built for FC6 and rawhide, thanks
Comment 21 Matthias Clasen 2006-12-09 00:08:08 EST
Built for FC5 too. 
Comment 22 Rex Dieter 2006-12-09 12:46:28 EST
Many thanks Mattias! (any idea when the FC-5/FC-6 updates will be available?)
Comment 23 Matthias Clasen 2006-12-09 18:15:13 EST
Should be in updates-testing as soon as jesse gets around to pushing them
Comment 24 Rex Dieter 2006-12-14 09:04:38 EST
saw it appear in updates(final) today, thanks, appears to work as advertised,
I'll take the liberty of closing this... unless you had some ulterior motive for
keeping it open... (:  
Comment 25 Rex Dieter 2007-01-26 08:42:50 EST
Re comment #21 : "Built for FC5 too."
I'm not seeing poppler-qt* in FC-5/updates or FC-5/updates-testing. ??
Comment 26 Rex Dieter 2007-02-23 15:19:26 EST
ping, any poppler/FC-5 updates coming?  I still don't see anything.
Comment 27 Rex Dieter 2007-04-13 08:17:20 EDT
another ~6 weeks, and I see nothing for FC-5 (in updates or updates-testing).
Either do and commit to what you said in comment #21 or say no, but to do nothing...
Comment 28 Matthias Clasen 2007-04-13 19:11:15 EDT
Sorry for the delay. I've pushed an fc5 update for this now. 
Comment 29 Rex Dieter 2007-04-14 11:24:28 EDT
Thanks!
Comment 30 Fedora Update System 2007-04-18 18:15:02 EDT
poppler-0.5.1-3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 31 Fedora Update System 2007-04-24 18:21:58 EDT
poppler-0.5.1-3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.