Bug 212315 - blktap does not build on ia64
blktap does not build on ia64
Status: CLOSED DUPLICATE of bug 216293
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Aron Griffis
: 209321 212642 (view as bug list)
Depends On: 208895
  Show dependency treegraph
Reported: 2006-10-26 04:03 EDT by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-18 15:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-10-26 04:03:49 EDT
+++ This bug was initially created as a clone of Bug #208895 +++

Description of problem:
The kernel/drivers/xen/blktap/blktap.ko module does not build on ia64:

drivers/xen/blktap/blktapmain.c: In function 'fast_flush_area':
drivers/xen/blktap/blktapmain.c:902: error: implicit declaration of function

Version-Release number of selected component (if applicable):

blktap has been disabled on ia64 for now:
$ grep TAP configs/*xen*
configs/config-xen-ia64:# CONFIG_XEN_BLKDEV_TAP is not set

-- Additional comment from chrisw@redhat.com on 2006-10-02 11:29 EST --
Created an attachment (id=137553)
blktap compile fix for ia64

-- Additional comment from chrisw@redhat.com on 2006-10-02 11:36 EST --
Here is a patch that gets things building.  It's a bit of a hack since
it copies create_lookup_pte_addr into ia64 specific source files.  With
this patch the thing builds, and boots.  However each of the blkback, netback
and blktap fail with the same error.  Basically none of the backend drivers are
working on ia64, they each fail in balloon_alloc_empty_page_range() due to
failed __get_free_pages() attempt with large order.

-- Additional comment from sct@redhat.com on 2006-10-02 12:15 EST --
Yes; the backend allocating issue is already being tracked as bug 202971.

-- Additional comment from chrisw@redhat.com on 2006-10-02 12:20 EST --
OK, in that case we could apply the blktap fix to get things working to a point
that they can be debugged.

-- Additional comment from prarit@redhat.com on 2006-10-04 12:00 EST --
Assigning to agriffis.

-- Additional comment from sakaia@jp.fujitsu.com on 2006-10-16 07:15 EST --
GNTMAP_application_map does not support Xen/IA64.
the blktap uses this function, so it does not run.
even if it fixes compilation.

-- Additional comment from yongkang.you@intel.com on 2006-10-16 22:10 EST --
This bug is still in kernel-xen-2.6.18-1.2784.fc6

-- Additional comment from dzickus@redhat.com on 2006-10-16 22:34 EST --
in kernel-2.6.18-1.2728.el5

-- Additional comment from sct@redhat.com on 2006-10-17 04:41 EST --
Reopening, because the el5 kernel is not a fix for a devel bug!

-- Additional comment from agriffis@redhat.com on 2006-10-25 14:22 EST --
Unfortunately the compile fix for blktap on ia64 isn't nearly enough.  Sure it
allows the module to build, and that's great so that it doesn't need to be
disabled.  However the requisite support isn't in the ia64 hypervisor yet.  See

Hopefully this will be fixed upstream in time for RHEL5 release.  Unfortunately
it didn't make FC6
Comment 1 Stephen Tweedie 2006-10-26 04:06:13 EDT
Can we get some idea of the effort involved here?  As things stand, this will
prevent file-backed domains from being created on ia64, as we are using blktap
by default these days on all file-backed PV domains (the blkback back-end is
Comment 2 Stephen Tweedie 2006-10-27 16:17:07 EDT
*** Bug 212642 has been marked as a duplicate of this bug. ***
Comment 3 Aron Griffis 2006-11-03 13:38:20 EST
*** Bug 209321 has been marked as a duplicate of this bug. ***
Comment 4 Aron Griffis 2006-11-08 15:23:55 EST
Isaku Yamahata (Fujitsu) finished this work.  It is now in xen-unstable:


Unfortunately blktap has diverged somewhat between xen-unstable.hg and RHEL5,
with unique fixes in each that haven't yet been merged to the other.  They'll
undoubtedly converge in due course, but at the moment this means a little
porting work for the above patches to apply to RHEL5.  I'll update this bug with
those soon, hopefully.
Comment 5 Aron Griffis 2006-11-18 15:53:44 EST

*** This bug has been marked as a duplicate of 216293 ***

Note You need to log in before you can comment on or make changes to this bug.