Bug 212343 - postfix complains about not finding localhost during install
postfix complains about not finding localhost during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On: 223428
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 09:48 EDT by Alexander Boström
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 09:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2006-10-26 09:48:51 EDT
Description of problem:

"yum install postfix" outputs this:

  Installing: postfix                      ######################### [1/1] 
postfix: fatal: config variable inet_interfaces: host not found: localhost

Version-Release number of selected component (if applicable):
postfix.i386 2:2.3.3-2

Steps to Reproduce:
1. Install FC6
2. yum install postfix
  
Additional info:
I did rpm -e postfix, changed "::1" to "127.0.0.1" in /etc/hosts and reinstalled
postfix, and the error message did not occur this time.
Comment 1 Thomas Woerner 2007-07-31 09:34:24 EDT
You have to have both entries in /etc/hosts:
127.0.0.1               localhost.localdomain localhost
::1             localhost.localdomain localhost

Closing as not a bug.
Comment 2 Alexander Boström 2007-07-31 09:39:28 EDT
Hmm... Maybe I should have filed this for anaconda instead. I'll reopen it if I
find that I can reproduce it in F7 or Fdevel.

Note You need to log in before you can comment on or make changes to this bug.