Bug 212454 - I just installed the yumextender, started it and received this error (Oct 26 2006)
I just installed the yumextender, started it and received this error (Oct 26 ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 16:29 EDT by G Robin
Modified: 2014-01-21 17:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 11:49:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G Robin 2006-10-26 16:29:01 EDT
Description of problem:
Component: yumex
Version: 1.0.2
Summary: TBd92eccef ConfigParser.py:462:_read:MissingSectionHeaderError: File
contains no section headers.
file: /etc/yum.repos.d/freshrpms.repo, line: 1
'main]\n'

Traceback (most recent call last):
  File "yumexmain.py", line 948, in ?
    mainApp = YumexMainApplication()
  File "yumexmain.py", line 452, in __init__
    self.repo = Repository()
  File "yumexUtils.py", line 1154, in __init__
  File "yumexUtils.py", line 1237, in update
  File "yumexUtils.py", line 1213, in build_section_dict
  File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 462, in _read
    raise MissingSectionHeaderError(fpname, lineno, line)
MissingSectionHeaderError: File contains no section headers.
file: /etc/yum.repos.d/freshrpms.repo, line: 1
'main]\n'

Local variables in innermost frame:
cursect: None
fp: <open file '/etc/yum.repos.d/freshrpms.repo', mode 'r' at 0xb7a5fb60>
e: None
fpname: /etc/yum.repos.d/freshrpms.repo
mo: None
optname: None
lineno: 1
line: main]

self: <ConfigParser.ConfigParser instance at 0xb79f61cc>


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-10-30 11:49:49 EST
You have a malformed repo config in /etc/yum.repos.d/freshrpms.repo.
Comment 2 Jeremy Katz 2006-10-30 11:51:44 EST
*** Bug 212553 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.