Bug 212553 - yum-updatesd/puplet ignores excludes
yum-updatesd/puplet ignores excludes
Status: CLOSED DUPLICATE of bug 212494
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 09:10 EDT by drago01
Modified: 2014-01-21 17:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 11:51:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2006-10-27 09:10:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):

yum-updatesd-3.0-6

How reproducible:

always

Steps to Reproduce:
Exclude a package; wait until there is a update for it
puplet will report it but pup will not find anything
Actual results:


Expected results:
it should read yum.conf and the repo files and ignore the packages listed in exclude

Additional info:
N/A
Comment 1 Andre Robatino 2006-10-27 09:48:06 EDT
  That explains it - I have the Freshrpms repo enabled but with its version of
libgpod excluded (since Core has an older version of the same package and I
don't need the newer one), and I keep getting told there is 1 update available.
  BTW, it would be nice to be given a list of the available packages, not just
told how many there are.  This functionality used to exist with rhn-applet, I
believe.
Comment 2 Rahul Sundaram 2006-10-27 22:19:12 EDT
The functionality of rhn-applet is replaced by Puplet.
http://lunapark6.com/wp-content/uploads/2006/10/FC6-01-securityupdates-640.jpg
Comment 3 Julian Sikorski 2006-10-28 18:04:24 EDT
The interesting thing happens if you have multiple excludes defined. My yum.conf
entry looks as follows:
exclude=openoffice.org-* freetype*
I have excluded these packages because I use vanilla openoffice.org due to bug
#171908 and freetype because I have recompiled it for BCI support. The thing is
that puplet says that there are 2 updates available, so it correctly excludes
openoffice.org and fails to do the same with freetype.
Comment 4 petrosyan 2006-10-28 22:12:30 EDT
this is a duplicate of bug #212494
Comment 5 Jeremy Katz 2006-10-30 11:51:29 EST

*** This bug has been marked as a duplicate of 212454 ***
Comment 6 Jeremy Katz 2006-10-30 11:51:49 EST

*** This bug has been marked as a duplicate of 212494 ***

*** This bug has been marked as a duplicate of 212494 ***

Note You need to log in before you can comment on or make changes to this bug.