Bug 21248 - Plurals of accented words
Summary: Plurals of accented words
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell-es   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-22 16:02 UTC by romano
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 13:20:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description romano 2000-11-22 16:02:53 UTC
The spelling check has a nasty bug: it fails on detect words were
pluralizacion means removing accents. I mean, this is correct:

singular --> plural
funcisn ---> funciones
seccisn ---> secciones

while aspell-es suggests funcisnes y seccisnes that are wrong. Now,
the use od the spell checker to correct accents is one of the most
common in spanish (at least for native speakers of a language that does
not graphically write emphasized sillables, like Italian).

The previous package (ispell) got that right. Between this and the lack of
a curses
interface, I am quite unhappy with the switch...

Comment 1 Trond Eivind Glomsrxd 2000-11-22 16:09:44 UTC
Are these words in the wordlist?

As for the switch, ispell is a dead, non-maintained application. Also, aspell is
a lot better at giving suggestions.

Comment 2 romano 2000-11-22 16:26:27 UTC
I think the problems is the following (sorry for the original message, I didn't
realiza that bugzilla
is not 8-bit clean, so I will now write o' for accented o - char 243 in
iso-latin1). 

"funcio'n" is in the wordlist: it is correctly accepted. 
when making the plural, you should add -es and drop the accent, obtaining
"funciones"

aspell-es does not drop the accent, saying that "funcio'nes" is correct. 

I tryed several -o'n words, and the problem is repeated. 

Thank you for the very fast answer, BTW!

Comment 3 Trond Eivind Glomsrxd 2000-11-22 16:39:00 UTC
It looks like the wordlist itself contains this word... if you know of any good
one, please tell (or spellcheck the current one :)

Comment 4 romano 2000-11-22 16:54:37 UTC
:-) I don't know if it's of any help... but the spanish wordlist 
of ispell by RedHat 6.2 was quite perfect.

Comment 5 Trond Eivind Glomsrxd 2000-11-22 17:17:34 UTC
I think I used that one to generate the new ones... anyway, I'll gladly accept
improved wordlists (see if you can extract a better one than I did for ispell),
but until that happens, there's not much I can't do about it.

Comment 6 romano 2000-12-04 09:25:14 UTC
I did find the time to have a look to it. The wordlist file did contain wrong 
spanish plurals. So I rebuilt a word list with this procedure: 

1) Installed old ispell.
2) Got the ispell-spanish source package. 
3) Generated the wordlist with expansions, sorted, and uniq-ed 
    with correct LC_ALL locale (es_ES). 
4)  Repeated the step I found in the spec-file of aspell-es. 

The results of all this you can find at  http://usuarios.tripod.es/r_mano/linux/
in the files: words.spanish.bz2, and the new binary and source aspell-es
package. Please feel free to take it and do with it whatever you want. 

I cannot assure this is the correct list, but I think that at this point is
exactly 
the same as the old ispell wordlist was.  I did not had to time to test it a
lot.

I do not change the bug status: I leave it in you hand. Bye,
                                                                                    
Romano



Comment 7 Trond Eivind Glomsrxd 2000-12-04 13:20:52 UTC
Thanks a lot, I'll incorporate the dictionaries soonish. Reopening to keep me
remembering :)

Comment 8 Trond Eivind Glomsrxd 2000-12-04 15:46:31 UTC
OK, I've created aspell-es-0.2-1 which includes the new, fixed dictionary and
should show up in Rawhide eventually. Thanks a lot for your help.


Note You need to log in before you can comment on or make changes to this bug.