Bug 212494 - puplet doesn't honor excluded packages in yum.conf
puplet doesn't honor excluded packages in yum.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 212553 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 20:25 EDT by Austin Foxley
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: yum-3.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 16:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Austin Foxley 2006-10-26 20:25:24 EDT
Description of problem:
If there are packages excluded from updates in yum.conf, puplet doesn't honor
them in reporting how many updates are available in the notification bubble

Version-Release number of selected component (if applicable):
pirut-1.2.5-1

How reproducible:
Set up an exclude list of packages that are set to be updated, and notice the 
the reported number of updates before and after is the same

Steps to Reproduce:
1. Wait for an update notification to appear (note number)
2. Edit yum.conf to include a line like "exclude=*" (or just one package)
3. Tell puplet to refresh (right click on the icon -> refresh)
4. Note number is not different
  
Actual results:
Available packages doesn't change. 

Expected results:
The user has explicitly asked to exclude those packages, so they shouldn't show
up in the count of updates.

Additional info:
Pup itelf honors the setting just fine.
Comment 1 Jeremy Katz 2006-10-30 11:52:13 EST
*** Bug 212553 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-11-06 15:19:59 EST
Did you restart yum-updatesd?  The config is only read when the daemon starts.
Comment 3 Andre Robatino 2006-11-06 15:23:38 EST
  It's been ignoring my exclude line (with Freshrpms) after many reboots, so
that's not the problem.  I haven't checked whether it ignores excludes for all
repositories or just the non-default ones.
Comment 4 Andre Robatino 2006-11-06 15:26:25 EST
  I should have mentioned that my exclude line is not in yum.conf, but in
/etc/yum.repos.d/freshrpms.repo.
Comment 5 Julian Sikorski 2006-11-06 15:28:59 EST
It seems it ignores excludes for all repos. My config entry looks as follows:
exclude=freetype* openoffice.org*
and puplet keeps telling me there are 2 updates available even though I have
updated all non-excluded packages.
Comment 6 Jeremy Katz 2006-11-06 16:16:15 EST
Okay, I think I've got this pretty happy now.  Can you grab
http://people.redhat.com/~katzj/yum-updatesd.py and replace
/usr/share/yum-cli/yumupd.py, restart yum-updatesd and see if it works better?
Comment 7 Julian Sikorski 2006-11-06 16:23:44 EST
Well, you mean to replace yumupd.py with yum-updatesd.py?
Comment 8 Andre Robatino 2006-11-06 16:27:38 EST
  Not being familiar with python, or with the roles of the 3 files yumupd.py,
yumupd.pyc, and yumupd.pyo, I just did exactly what you said, replacing
yumupd.py with yum-updatesd.py (assuming that the fact that the name is
different is okay), ignoring the other two files.  No change.
Comment 9 Julian Sikorski 2006-11-06 16:45:44 EST
Well, I replaced the file and now the puplet icon does not appear anymore. It
sometimes takes a while, though. Maybe I am just not patient enough.
Comment 10 Nicholas Miell 2006-11-06 17:03:25 EST
Fixes it for me.


Andre -- did you do "service yum-updatesd restart" ?

Julian -- try running "dbus-send --system --print-reply --type=method_call
--dest=edu.duke.linux.yum /Updatesd edu.duke.linux.yum.CheckNow"
Comment 11 Andre Robatino 2006-11-06 17:10:24 EST
  I did restart yum-updatesd.  But I'm not clear on exactly what I was supposed
to do.  I renamed the existing yumupd.py to yumupd.py.tmp, and then copied the
file yum-updatesd.py into the same directory (_without_ changing the name to
yumupd.py) - is this correct?
Comment 12 Nicholas Miell 2006-11-06 17:20:05 EST
(In reply to comment #11)
>   I did restart yum-updatesd.  But I'm not clear on exactly what I was supposed
> to do.  I renamed the existing yumupd.py to yumupd.py.tmp, and then copied the
> file yum-updatesd.py into the same directory (_without_ changing the name to
> yumupd.py) - is this correct?

No, you should've done "mv yum-updatesd.py /usr/share/yum-cli/yumupd.py"
Comment 13 Andre Robatino 2006-11-06 17:25:33 EST
  Okay, now the puplet icon doesn't appear anymore, so it seems fixed for me as
well.
Comment 14 Austin Foxley 2006-11-06 18:20:59 EST
Works great here as well. Thanks for the fix. 
Comment 15 Julian Sikorski 2006-11-07 02:47:12 EST
It seems to be fixed because pup returns the same number of updates as puplet.
THe other question is: is the icon supposed to be visible when there are no
updates? It was visible for me and after I ran pup, updated the system and hit
refresh it disappeared. I alco ran the command Nicholas suggested:
[jsikorski@fcdesktop ~]$ dbus-send --system --print-reply --type=method_call
--dest=edu.duke.linux.yum /Updatesd edu.duke.linux.yum.CheckNow
method return sender=:1.1 -> dest=:1.12
   string "check queued"
Is this the expected behaviour?
Comment 16 Fedora Update System 2006-11-10 13:16:30 EST
yum-3.0.1-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 17 Fedora Update System 2006-11-16 18:08:20 EST
yum-3.0.1-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.