Bug 212516 - unshield md5 checksums always fail on x86_64
unshield md5 checksums always fail on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: unshield (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 212707 (view as bug list)
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-27 03:49 EDT by Alex W. Jackson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 18:09:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: fixing md5 sum code on 64 bit (440 bytes, patch)
2006-11-16 16:41 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Alex W. Jackson 2006-10-27 03:49:58 EDT
Description of problem:
The x86_64 build of unshield is completely broken and unusable.  It always
reports an MD5 checksum failure for every single file in every cabinet you
attempt to extract or test.

Version-Release number of selected component (if applicable):
unshield-0.5-3.fc5

How reproducible:
Attempt to extract or test any InstallShield cabinet using unshield

Actual results:
unshield will report an MD5 checksum failure for every single file in the
cabinet, and fail to extract the files

Expected results:
MD5 checksum failures should only occur if the cabinet is actually damaged

Additional info:
Googling for "unshield md5", I came across this:

http://ports.openbsd.nu/archivers/unshield

Note the commit dated 2006-10-18.  Apparently, unshield contains its own
implementation of md5 which is not 64-bit-clean code.  The OpenBSD package
maintainer fixed the issue by making unshield use the system md5 (OpenBSD has
md5 in their libc) instead of its own implementation.  We don't have that
luxury, so it looks like we'll have to actually fix unshield's md5 (or rip it
out and replace it with the one from coreutils, but I don't think they're
license compatible)
Comment 1 Michael Schwendt 2006-10-28 05:50:19 EDT
*** Bug 212707 has been marked as a duplicate of this bug. ***
Comment 2 Hans de Goede 2006-11-16 16:41:11 EST
Created attachment 141419 [details]
PATCH: fixing md5 sum code on 64 bit

Hi,

Since I've gotten quite good in fixing 64 bit bugs I've taken a quick look
at this. Fixing it turns out to be rather trivial, take a look at the attached
patch.

If you're short on time I can drop this and an updated spec in CVS and requests
builds if you want me to.
Comment 3 Andreas Bierfert 2006-11-16 18:09:17 EST
thanks for helping out with this :) pushed for fe-{3,4,5,6} and devel :)
Comment 4 Hans de Goede 2006-11-17 11:31:18 EST
p.s.

1) Don't forget to also send this upstream, so that other distros can pick this 
   up eventually.

2) Offtopic, have you received my scummvm-tools mail? Is it ok for me to update
   it to the latest and submit to FE, or do you want todo that?

Note You need to log in before you can comment on or make changes to this bug.