Bug 212603 - installation stops, cannot unmount /mnt/source
installation stops, cannot unmount /mnt/source
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
: 212395 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-10-27 14:00 EDT by Sander
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-26 13:40:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda.log and dmesg (8.91 KB, application/x-gzip)
2007-02-01 15:45 EST, Marek Mahut
no flags Details

  None (edit)
Description Sander 2006-10-27 14:00:05 EDT
Description of problem:
When upgrading from FC5 to FC6 the following error occures while checking depencies.

An error occurred unmounting the CD. Please make sure you're not accessing
/mnt/source from the shell on tty2 and then click OK to retry

How reproducible:
Run the installeren (graphical or text mode) select upgrade. The error occures
while checking depencies.

Actual results:
error message and not able to solve the problem. Have to restart the system.

Expected results:
Continue with the installation.

Additional info: With ALT+F2,3,4 I found couple of messages with a bad-block on
device hdc. But in the installer I ran the check and that was fine.
Also I am using the DVD-version, so don't know why the system wants to umount
the DVD in the middle of the process.
Comment 1 Sander 2006-10-29 12:14:24 EST
Some extra information
The installation worked perfectly when using my other DVD-drive.

hdc: Optiarc DVD RW AD-5170A, ATAPI CD/DVD-ROM drive
hdd: Pioneer DVD-ROM ATAPIModel DVD-106S 012, ATAPI CD/DVD-ROM drive

hdc gave problems with unmounting
and hdd was working perfectly.
Comment 2 Jeremy Katz 2006-10-30 14:31:57 EST
This sounds like a case of marginal media/drive compatibility.  Not much we can
really do about it.
Comment 3 Sander 2006-10-30 14:51:23 EST
The drive (hdc) was reading the DVD and was running the installation. But failed
at the point 'checking depencies'.
I don't see it as a media/drive compatibility.
Comment 4 shrek-m 2006-12-01 07:58:04 EST
the same here.
`sha1sum -c` was ok but the media-check was failing both time
`growisofs -Z /dev/scd0=*DVD.iso` was 100% ok

i tried a clean fresh fc6-i386-dvd text-install
"office-productivity + windows-server"
while checking dependencies anaconda can not umount hdc

`mount` gives  "/tmp/cdrom /mnt/source iso9660"
`ls /mnt/source/` is ok and the dvd is mounted
but "/tmp/cdrom/"  does not exist
`umount -f /mnt/source/` is not possible, this could be the problem.

the second try without "windows-server" was ok and /tmp/cdrom/" was all the time ok

the same notebook
the same dvd (qsi dvd-rom sdr-081)
the same media (dvd+r 4,7 gb)
Comment 5 shrek-m 2006-12-01 10:58:08 EST
this media (fc6-dvd) is bootable on this notebook and the second installation
was ok.
but after the installation this media is no longer readable under fc6 on this
notebook while windows 2000 (dualboot) has abolutely no problems on this
notebook with this media in this drive.
the media has no problems on at least 4 other machines, mac-mini, powerbook,
powermac, athlon_64
Comment 6 Marek Mahut 2007-02-01 15:45:25 EST
Created attachment 147140 [details]
anaconda.log and dmesg

Hello all,

I got the same problem during installation of fedora core 6 on my notebook at 
work - and I can reproduce it. The problem appears only with extra repo - in 
fact my interface got a ip address from local dhcp server and try to get 
repomd.xml from fedora's mirror for extras. The only problem is that I'm 
accessing internet at work thought ISA proxy. There's no problem when I install

it without extras. I think that this happens when anaconda fails to connect and

can't get repomd.xml - to check. Find attached informations about install. In
case you want some more investigation of this issue, don't hesitate to mail me
- but I leave me actuall work on first March... :)


Comment 7 Karthik Ganesan 2007-02-14 11:38:52 EST
I got the same behavior as Marek - If I do not select fedora extras, the
installation goes through
Comment 8 Chris Lumens 2007-02-22 15:49:08 EST
*** Bug 212395 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2007-02-26 13:40:01 EST
All of the comments from other than the original reporter are about a separate

For the original case, please ensure that the media is verified with mediacheck
and also try burning at a slower speed as that will often help with drive/media

Note You need to log in before you can comment on or make changes to this bug.