Bug 212621 - xmms doesn't load (Gdk-ERROR)
xmms doesn't load (Gdk-ERROR)
Status: CLOSED DUPLICATE of bug 213172
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 14:53 EDT by Russell McOrmond
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 08:37:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell McOrmond 2006-10-27 14:53:32 EDT
Description of problem:

I recently upgraded from FC5 to FC6.  When I try to load xmms I get the
following error.

>xmms
XS[src/xmms-sid.c:xs_init:216]: xs_init()
XS[src/xs_config.c:xs_init_configuration:164]: initializing configuration ...
XS[src/xs_config.c:xs_read_configuration:265]: loading from config-file ...
XS[src/xs_config.c:xs_read_configuration:320]: OK
XS[src/xmms-sid.c:xs_reinit:163]: initializing emulator engine #1...
XS[src/xmms-sid.c:xs_reinit:177]: init#1: OK, 1
XS[src/xmms-sid.c:xs_reinit:189]: init#2: OK, 0
XS[src/xmms-sid.c:xs_init:226]: OK
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2467 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2468 error_code 8 request_code 72 minor_code 0



Version-Release number of selected component (if applicable):

All 'xmms' related packages installed:

>rpm -qa | grep xmms 
xmms-modplug-2.05-7.fc6
xmms-scrobbler-0.3.8.1-2.fc6
xmms-crossfade-0.3.11-1.fc6
xmms-lirc-1.4-9.fc6
xmms-arts-0.7.1-4.fc6
xmms-cdread-0.14-12.fc6
xmms-xosd-2.2.14-8.fc6
xmms-sid-0.8.0-0.3.beta15.fc6
xmms-acme-0.4.3-6.fc6
xmms-alarm-0.3.7-5.fc6
xmms-adplug-1.2-3.fc6
xmms-esd-1.2.10-28.fc6
xmms-devel-1.2.10-28.fc6
xmms-speex-0.9.1-8.fc6
xmms-libs-1.2.10-28.fc6
xmms-flac-1.1.2-27.fc6
xmms-1.2.10-28.fc6
xmms-musepack-1.2-3.fc6

How reproducible:

Any time I try to run, as any user.

Steps to Reproduce:
1. Run xmms
2. ???
3. Profit  (smiles)
  
Actual results:


Expected results:


Additional info:

Normally I also have some additional modules for aac and mp3 installed from
freshrpms, but removed them in the off chance they were causing problems.
Comment 1 Ville Skyttä 2006-11-05 16:14:52 EST
xmms is in Fedora Extras, moving/reassigning.

Anyway, I tried to reproduce and installed all the plugins you listed, but it
starts up just fine here on FC6 x86_64.

Just a hunch, could you try the workaround from bug 213172 comment 2 and see if
it has any effect?
Comment 2 Russell McOrmond 2006-11-06 08:37:48 EST
Seems this is a duplicate of bug 213172.  The suggested workaround works.

*** This bug has been marked as a duplicate of 213172 ***
Comment 3 David Timms 2006-11-07 02:29:27 EST
Russell: without the workaround, can user root start xmms successfully {this is
what I see} ?
Comment 4 Russell McOrmond 2006-11-07 08:39:52 EST
I believe what you are asking is whether it loads when doublesize is not
enabled.  I can remove (or otherwise move out of the way) the ~/.xmms directory
and then it will load.  As soon as I try to move to doublesize it screws up.
Comment 5 David Timms 2006-11-07 08:55:46 EST
Well, I wasn't, but you answered in a way. I found that as root xmms loads and
runs OK, and only bombs once doublesize is enabled.

As normal user I only got the error messages you listed above. But I see what
you mean: in fact that was a user profile from fc5 (and before) that has
doublesize=true in the config. So my issue is in fact identical, thanks Russell.

Note You need to log in before you can comment on or make changes to this bug.