Bug 213172 - Xmms crashes when doubling size
Xmms crashes when doubling size
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 212621 213598 213825 214478 214565 (view as bug list)
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-30 20:28 EST by Greg Huber
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.2.10-29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 16:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Huber 2006-10-30 20:28:56 EST
Description of problem:
After starting Xmms, the app will crash and hang with the following error;

Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 3357 error_code 8 request_code 72 minor_code 0

The app must be killed at this point.



Version-Release number of selected component (if applicable):

xmms-devel-1.2.10-28.fc6
xmms-cdread-0.14-12.fc6
xmms-libs-1.2.10-28.fc6
xmms-flac-1.1.2-27.fc6
xmms-1.2.10-28.fc6
xmms-arts-0.7.1-4.fc6
xmms-skins-1.2.10-15



How reproducible:
Happens every time.


Steps to Reproduce:
1) Start the app, 
2) click on the 'D' icon
or select Options->Double Size
or type >ctrl>d while the cursor is on the app.

  
Actual results:
A window filled with garbage, but about the 
correct size appears but the app is dead.


Expected results:
A double size view of the current skin should appear


Additional info:
Comment 1 Michael Schwendt 2006-10-31 16:12:38 EST
Same as bug 166469?
Comment 2 Ville Skyttä 2006-10-31 16:23:02 EST
Yep, the same, known upstream bug: http://bugs.xmms.org/show_bug.cgi?id=1907

Workaround: In a shell before starting xmms, do:

    export XLIB_SKIP_ARGB_VISUALS=1

To make this permanent in the menu entry, change the Exec= line in
/usr/share/applications/redhat-audio-player.desktop to:

    Exec=env XLIB_SKIP_ARGB_VISUALS=1 xmms -e %F

...or of course, a wrapper script could be created for launching xmms, perhaps
moving the original executable to /usr/libexec/xmms and calling that from the
wrapper in /usr/bin.
Comment 3 Greg Huber 2006-11-01 13:14:51 EST
Setting XLIB_SKIP_ARGB_VISUALS=1 before starting xmms works.
Thank You.
Comment 4 Ville Skyttä 2006-11-02 11:55:55 EST
*** Bug 213598 has been marked as a duplicate of this bug. ***
Comment 5 Ville Skyttä 2006-11-03 13:42:59 EST
*** Bug 213825 has been marked as a duplicate of this bug. ***
Comment 6 Russell McOrmond 2006-11-06 08:37:51 EST
*** Bug 212621 has been marked as a duplicate of this bug. ***
Comment 7 Ville Skyttä 2006-11-06 16:19:55 EST
Wrapper script workaround applied in 1.2.10-29.fc* which will enter the FC6+
repos in the next push.
Comment 8 Ville Skyttä 2006-11-08 02:03:55 EST
*** Bug 214478 has been marked as a duplicate of this bug. ***
Comment 9 Ville Skyttä 2006-11-08 13:24:28 EST
*** Bug 214565 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.