Bug 212692 - New package: libgnomekbd
New package: libgnomekbd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FC-ACCEPT
  Show dependency treegraph
 
Reported: 2006-10-28 01:21 EDT by Matthias Clasen
Modified: 2013-01-09 23:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 23:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-28 01:21:19 EDT
The next versions of control-center and a number of other desktop packages will
depend on a new library called libgnomekbd:

http://people.redhat.com/mclasen/review/libgnomekbd-0.1-2.src.rpm
http://people.redhat.com/mclasen/review/libgnomekbd.spec
Comment 1 Bill Nottingham 2006-10-30 11:55:18 EST
Is this built on top of libxklavier - i.e., gui widgets for keyboard config?
Comment 2 Matthias Clasen 2006-10-30 16:36:45 EST
It contains interfaces for accessing and storing keyboard configuration,
keyboard drawing interfaces (this is in fact built on top of libxklavier), 
and a keyboard indicator widget (basically the thing you currently see in the
keyboard-indicator applet.

The reason for moving this stuff out into a real library is that people want to 
be able to switch keyboard layouts in the gdm login screen and the screensaver
lock dialog, and proliferation of virtual cvs modules is not the right answer
for that.
Comment 3 Ray Strode [halfline] 2006-11-02 12:33:08 EST
the description has %{name} in it, that's weird
Comment 4 Ray Strode [halfline] 2006-11-02 12:35:33 EST
I think we have a policy of putting a full URL in the Source line
Comment 5 Ray Strode [halfline] 2006-11-02 12:41:32 EST
It says it requires dbus-glib >= 0.34.  Is that really right? isn't it at
version .7something now?

why does this *library* ship a capplet?  What does it do? Can we just nuke it
and not put it in the package?

Also what is the output of rpmlint? any warnings or errors?
Comment 6 Matthias Clasen 2006-11-02 12:53:27 EST
I don't have a source url, unless you want me to put in the sourceforce download
url. Its not in gnome ftp yet.

Regarding dbus-glib version, I just copied whatever versions the configure
script requires. But if it freaks you out' I'll bump it.

The capplet is for configuring the plugins. I know it is slightly ridiculous,
thats why I have made it NoDisplay. I was not totally sure about leaving it out.
On the one hand, having plugins in a keyboard indicator is nonsense, and we
don't ship any in core anyway, but on the other hand there are many flag lovers
out there who would maybe install the flags plugin if it was packaged in extras.

I guess whoever decides to package the plugins could also package the capplet 
in extras then.
Comment 7 Matthias Clasen 2006-11-02 12:57:20 EST
Also, aren't reviewers supposed to run rpmlint themselves ? Anyway, it comes up
clean
Comment 8 Ray Strode [halfline] 2006-11-02 13:00:57 EST
Okay moving to FC-ACCEPT.

Comment 9 Jesse Keating 2006-11-02 14:22:02 EST
Package added to dist-fc7, please close bug when built for rawhide.
Comment 10 Jules Colding 2006-11-09 06:21:43 EST
Not sure if this is the right place, but todays yum update gave me:

Transaction Check Error:   file
/etc/gconf/schemas/desktop_gnome_peripherals_keyboard_xkb.schemas from install
of libgnomekbd-2.17.2-1.fc7 conflicts with file from package
control-center-2.17.1-2.fc7

-- 
  jules
Comment 11 Jules Colding 2006-11-09 08:57:19 EST
OK, it works now.

Thanks,
  jules

Note You need to log in before you can comment on or make changes to this bug.