Bug 21272 - cannot dump fs other than /
cannot dump fs other than /
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Dale Lovelace
:
: 21273 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-22 22:15 EST by ae
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 15:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ae 2000-11-22 22:15:47 EST
cannot dump fs other than /

EXAMPLE:

LIST="/var /"

for j in $LIST; do
	/sbin/dump 0bBuf 48 500000 /dev/nst0 $j
done

export TAPE=/dev/st0
mt rewind

/sbin/restore is 1
. is not on the tape
Root directory is not on tape
abort? [yn] n
/sbin/restore > ls
/sbin/restore > quit

[root@dogsbody /var]# /sbin/restore is 2
/sbin/restore > ls
.:
.bash_history  dos            net            tmp--          u6 
bin            etc            opt            u1             u7 
boot           home           proc           u10            u8 
burner         info           roast          u11            u9 
cdrom          lib            root           u2             usr 
cdrom4         lost+found/    sbin           u3             var 
cdrom6         misc           tftpboot       u4 
dev            mnt            tmp            u5 

/sbin/restore > quit



Tested other way around; in thad case file 1 looks like my root,
and file 2 DOES NOT show anything.


------------------------------------------------------------------------
[ maybe related, maybe independant. ]
Trouble with writing multiple tape files from Solaris client; can
see only the last in the set.  This worked OK a while ago.
Am using the no-implicit-rewind device /dev/nst0.

dump-0.4b19-5.6x
kernel-smp-2.2.16-3
rmt-0.4b19-5.6x
Comment 1 Bill Nottingham 2000-11-24 00:31:03 EST
*** Bug 21273 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2001-11-21 23:03:16 EST
Can you test dump 0.4b25 from rawhide?  It is believed that
this problem is now not reproduceable in this release.
Comment 3 Stelian Pop 2002-04-25 15:33:35 EDT
I think this bug could be closed now...
Comment 4 Mike A. Harris 2002-04-25 18:35:52 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.