Bug 212732 - yum-updatesd doesn't know I'm using NetworkManager
Summary: yum-updatesd doesn't know I'm using NetworkManager
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
: 228268 249200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 15:23 UTC by Bastien Nocera
Modified: 2014-01-21 22:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 17:48:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2006-10-28 15:23:54 UTC
1. Set up NetworkManager on your machine (chkconfig NetworkManager on; service
NetworkManager start)
2. log in
3. Have yum-updatesd complain about missing network connectivity

This won't be true a couple of seconds afterwards, when NetworkManager connects
to the wireless network.
Adding NetworkManager support would also allow for the notification area icon to
go away, as there wouldn't be any needs for yum-updatesd to present a "refresh"
button. The icon would only be there when there are updates to be installed.

Comment 1 Jeremy Katz 2006-10-30 17:00:56 UTC
Seems reasonable; I'll try to throw something together soon-ish.

Comment 2 Jeremy Katz 2006-11-06 21:39:39 UTC
Hrmmm, this is a little problematic at present due to start order. 
NetworkManager starts way late (98) and that's after yum-updatesd.

If this it to be reasonable to consider, then NetworkManager is going to have to
start earlier; likely on par with when networking normally starts

Comment 3 Adam Huffman 2007-02-07 21:49:18 UTC
Yes, I see this every time on my laptop.  The message from yum-updatesd appears
whilst I'm typing in the gnome-keyring password, which is obviously needed in
order for the wireless connection to work.

Comment 4 Jeremy Katz 2007-02-14 16:18:22 UTC
*** Bug 228268 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2007-07-24 21:49:33 UTC
*** Bug 249200 has been marked as a duplicate of this bug. ***

Comment 6 Wade Mealing 2007-07-24 23:51:02 UTC
This still happens on fresh F7 install and package update.

Comment 7 Jeremy Katz 2007-09-13 17:48:48 UTC
yum-updatesd knows about the status of NetworkManager now and sends messages
appropriately.  puplet is still notifying on the failure, but that's going to be
delayed to the second failure soon (as knowing that you're not receiving updates
because you're not online does have value; we just want to avoid the case of
where you just logged in)


Note You need to log in before you can comment on or make changes to this bug.