Bug 212741 - Voodoo3 AGP crashes Xorg and Anaconda
Voodoo3 AGP crashes Xorg and Anaconda
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-10-28 12:28 EDT by Doug Baggett
Modified: 2008-08-02 19:40 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-11 20:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patched rpm for i386 builds (37.87 KB, patch)
2006-11-20 15:43 EST, Roc Halbasch
no flags Details | Diff
xorg.conf before moving it out of the way (567 bytes, text/plain)
2007-01-16 16:25 EST, Paul Long
no flags Details
Xorg.0.log before I moved xorg.conf out of the way (35.70 KB, text/plain)
2007-01-16 16:29 EST, Paul Long
no flags Details
Xorg.0.log _after_ I moved xorg.conf out of the way (39.58 KB, text/plain)
2007-01-16 16:31 EST, Paul Long
no flags Details

  None (edit)
Description Doug Baggett 2006-10-28 12:28:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
On upgrade of an FC5 i386 system to FC6, anaconda runs the Graphical X installer after detecting my AGP based Voodoo3, starts to run (X Server comes up..can move the X cursor around for a couple of seconds) then hard crashes (freeze) to a white screen that is unrecoverable and also kills the keyboard (num lock/caps lock fails to work).

AFter a complete upgrade (using text mode) I tried to log in using startx, my gnome desktop comes up. But no cursor and once again the keyboard freezes. The system is still running (I can log in via SSH remotely). No errors are written in the xorg log?!!

Just runing "X" from command line seems to work...so is this an "X" problem or a problem with Gnome or Anaconda? Confused I am...totally reproduceable.

If somebody needs a video I could take a shot with my camera and send it to somebody.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Startx

Actual Results:
Frozen screen/keyboard mouse cursor missing

Expected Results:
unfrozen screen...keyboard and mouse working.

Additional info:
Comment 1 Carl Preddy 2006-10-30 20:12:46 EST
Very similar experience with Voodoo3 2000 AGP on ABIT NF7-S Nforce2 mb. Cannot
install FC6 as an upgrade to FC5 (which worked fine)in graphical mode. After
anaconda starts it initiates Xserver, reports correct card detection, says
something about a log file that is too brief to read, presents Big X, then the
DNA Splash Screen of Death. Reproducibly frozen. Switching to text mode install
appears to work, but at the end of the long and winding road the system
manifests runlevel 5, lets me log in, shows me my desktop briefly, then
collapses back to the login screen. Its a beautiful design but not that useful.
In contrast, I first installed FC6 from the same media over FC5 on an older
P-III box with an even more primitive video card and it went flawlessly. This is
the first time I have ever encountered a showstopping problem with any FC
release. Seems like it could be Xorg related. 
Comment 2 ejaquay 2006-10-30 20:36:11 EST
Simular experiance with nvidia AGP driver.  After startup locks with blank
screen single underscore character in upper left hand corner.  System freezes
every boot at run level 5.  Simple work around it to start system at run level
3.  After level 3  startup completes then startx and every thing seems OK,
desktop effcts work, etc.
Comment 3 Carl Preddy 2006-11-01 17:27:54 EST
Workaround not effective here. from level 3 startx displays desktop but no
cursor|kb|mouse(but still background activity). Further info:
- one fatal during boot sequence loading acpi-cpufreq
- uname: 2.6.18-1.2798.fc6 #1 SMP .. i686 athlon i386 GNU/Linux
- misstatement in previous post: Voodoo3 is PCI, not AGP; lspci detects properly
- Xorg.log (EE) TDFX(0): [dri] tdfx DRI not supported in 32 bpp mode, disabling
DRI. (EE) AIGLX: Screen 0 is not DRI capable
Saw a log message the X server didn't have permission to connect to host; is
this some weird magic-cookie or xhost permissions thing? Did xhost +localhost
but did not help. 
Comment 4 Tomaso Dall'Anese 2006-11-03 20:04:10 EST
I can confirm the problem on fc6 with a Voodoo3 card. As a workaround you can
disable acceleration:
Option "NoAccel" "Off" 

in the Driver section of /etc/X11/xorg.conf

or use the vesa driver instead of the tdfx one. It will work but with very poor

I suppose there's a problem with aiglx.

Please help us.
Comment 5 Michael McTernan 2006-11-04 07:38:56 EST
A clean install of FC6 shows the same problem for me.  Dropping the resolution
to 800x600 (using system-config-display) allows X to start without the display
and keyboard hanging.
Comment 6 Lokesh Sharma 2006-11-06 08:52:38 EST
I also have the same card ( Voodoo3 AGP ) and same problem. Graphical session
crashes. So far I have tried these things --
Created new configuration file using "Xorg -configure" then used this
configuration file to start X server using "Xorg -config xorg.conf.new". The
xserver starts up and nothing freezes. "startx" still result in system hang. I
started xserver with xterm using "xinit bash -- -config xorg.conf.new" this
gives me a xterm. But if I try to start "gnome-session" here it hangs. 
I changed the driver from "tdfx" to "vesa", but could not get gnome to start.
Although I was able to start "firefox" in a xterm session with "vesa" driver. 
Comment 7 Guy Davis 2006-11-07 12:14:30 EST
Not sure if this is any consolation, but FC6 isn't the only distro affected:
Comment 8 Roc Halbasch 2006-11-16 19:02:38 EST
Same here with Voodoo 5 5500 AGP
Comment 9 Mike 2006-11-16 22:30:28 EST
Yep, same here with an AGP Voodoo3.  Worked great on FC5.  I am able to log in
as root when I have the resolution set at 800x600 (as suggested in Comment #5
above) and gnome does start.  If I log in as a regular use at 800x600 the screen
just blinks a couple of times and takes me to the login screen.

I checked out the Fedora Wiki site that discusses AIGLX and compiz (at
http://fedoraproject.org/wiki/RenderingProject/aiglx) and there is a small blurb
under "Video card status" -> "Occasionally / Possibly Working" that says that
"3dfx: voodoo3 through voodoo5. Might need NV_texture_rectangle emulation." I've
googled that and get no information.  Does anyone know what this
NV_texture_rectangle emulation is and how to enable it?  Perhaps it has
something to do with this....
Comment 10 Roc Halbasch 2006-11-17 13:49:26 EST
has amyome tried the patch for tdfx @ 
Comment 11 Roc Halbasch 2006-11-17 16:18:31 EST
I tried the patch I recompiled tdfx and then removed the original
xorg-x11-drv-tdfx package and then installed my patched one and the system now
runs X using the tdfx driver. The only problem is I can't seem to get it to
display anything higher than 800x600 does anyone know how to fix this?
Comment 12 Guy Davis 2006-11-17 16:26:40 EST
Here's a workaround to get decent resolutions.  This is NOT a fix however.

Add to your /etc/X11/xorg.conf in: 
Section "Screen"

The line:
Option      "Accel" "no"

Then reboot your system or just restart X.

This lets me run at higher resolutions as root and regular users with no more
lockups.  Only drawback is that browsing in Firefox is a bit of pain without
graphics acceleration, particularly the scrolling.  Everything else seems fine
Comment 13 Roc Halbasch 2006-11-17 16:59:37 EST
I meant that the system says 800x600 is the highest available resolution even 
though my xorg.conf say's it can do higher. 
Comment 14 Roc Halbasch 2006-11-18 09:07:44 EST
Ok so I fixed it on my system. I have it running at 1280x1024 with acceleration
on and using the tdfx driver and all runs perfectly. Here's how I did it some
changes will be needed on a non i386 install

1. Downloaded the tdfx SRPM from 

2. Extracted the three files from the srpm using archive manager:

3. Copy xf86-video-tdfx-1.2.1.tar.bz2 and tdfx.xinf to /usr/src/redhat/SOURCES

4. Use archize manager to extract src/tdfx_priv.c from xf86-video-tdfx-1.2.1.tar.bz2

5. Edit tdfx_priv.c and add the two lines in the patch found here.

6. Use archive manager to write over the src/tdfx_priv.c in
xf86-video-tdfx-1.2.1.tar.bz2 with the edited one.

7. Make sure you have the xorg-x11-server-sdk package installed and the packages
 that include the basic development tools such as gcc so you can compile.

8. Run "rpmbuild -ba xorg-x11-drv-tdfx.spec" and wait for it to compleate. You
should get no errors.

9. Make sure that it created the file

9. Run "yum remove xorg-x11-drv-tdfx" and wait.

10. Run "rpm -ivh /usr/src/redhat/RPMS/i386/xorg-x11-drv-tdfx-1.2.1-3.1.i386.rpm"

11. Run "yum install xorg-x11-drivers"

12. Now you should be able to run X with this new tdfx driver with no problem at

13. If you have any problems with resolution run "Xorg -configure" and use the
new xorg.conf.new by renaming it to xorg.conf and copying it to /etc/X11/ don't
forget to backup your old xorg.conf first just in case.

Forgive me if this was long winded just wanted to make sure it was clear enough
for anyone to follow.
Comment 15 Roc Halbasch 2006-11-20 15:43:18 EST
Created attachment 141692 [details]
patched rpm for i386 builds

Here is the patched rpm I built for the tdfx driver you need to use yum to
uninstall the original from the install then install this one and all should
work fine.

Sorry I don't know this bugzilla system very well if I knew I could attach this
a couple of days ago I would have.
Comment 16 Kevin 2006-12-08 22:37:48 EST
I can also confirm this same bug on a VooDoo5 5500 AGP on a 686 using a fresh
install via text method.
Comment 17 Roc Halbasch 2006-12-09 17:17:26 EST
there is a new version of the driver in the updates-testing repo update to 
that and it should fix alot of the problems
Comment 18 Matěj Cepl 2006-12-27 14:56:11 EST
Doug, can we get back to basics, please?

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 19 Paul Long 2007-01-16 16:25:21 EST
Created attachment 145739 [details]
xorg.conf before moving it out of the way

X11 never created a new xorg.conf when I rebooted without one. Don't know if
it's supposed to.
Comment 20 Paul Long 2007-01-16 16:27:04 EST
I have the same problem. I have attached my original Xorg.0.log (as
Xorg.0.log.old in attachment) and xorg.conf files. After I renamed the latter,
rebooted in text, and did startx, X11 created a new Xorg.0.log. I have a 3dfx
VooDoo 3 board and Dell E550 monitor.

Background: I couldn't do graphical install. Would end up in various versions of
the first install screen where the buttons at bottom were not displayed. Would
either get totally white screen, fedora blue window on white background, or
fedora blue window and fedora banner across top with white background. Buttons
and keyboard would apparently work--I just couldn't see 'em. I tried various
combinations of these "linux" parameters: resolution=800x600 lowres noprobe
acpi=off skipddc. Different results (see above) but nothing worked.

Text install worked. Not sure whether relevant, but these are all of the boot

1. FATAL: Error inserting acpi_cpufreq (...) No such device
2. Starting sendmail:  [OK]    <-- OK, but takes a few minutes to respond
3. Starting sm-client: [OK]    <-- OK, but takes a few minutes to respond
4. hda: drive_cmd: status=0x51 ( DriveReady SeekComplete Error )
   hda: drive_cmd: error=0x04 ( DriveStatusError )
   ide: failed opcode was 0xb0

Now, when I boot in text mode and run startx, I get the full gnome desktop but
without the mouse cursor or keyboard input--it's locked up. I can still SSH into
the box, though. When I boot directly into graphics mode (change to
id:5:initdefault: in /etc/inittab), I am presented with a gray rectangle towards
the bottom half of screen with darker gray rectangle (a line of text blocks?)
within that, all on a black background. I can, again, SSH into the box.

Any ideas guys? Is there consensus on what the fix or best workaround is?
Comment 21 Paul Long 2007-01-16 16:29:38 EST
Created attachment 145740 [details]
Xorg.0.log before I moved xorg.conf out of the way
Comment 22 Paul Long 2007-01-16 16:31:08 EST
Created attachment 145741 [details]
Xorg.0.log _after_ I moved xorg.conf out of the way
Comment 23 Paul Long 2007-01-16 17:32:41 EST
(In reply to comment #20)

It's better now, after loosely following Roc Halbasch's instructions. This is
what I did:

# wget
# yum remove xorg-x11-drv-tdfx
# rpm -ivh xorg-x11-drv-tdfx-1.3.0-2.fc6.i386.rpm
# yum install xorg-x11-drivers
# reboot

I can now see the gnome desktop, use the mouse, and have the system respond to
keyboard input. However, there is a problem painting the screen. It first shows
up right after logging on--the login screen remains as the desktop background,
e.g., I can still see "fedora  Password: ***********" as my background and the
"Language Sesison Restart Shut Down" text at the bottom of the screen. If I move
stuff over the background, e.g., the drop-down menus, the "real" background
shows up. Weird. And sometimes the "Computer," "root's Home," and "Trash" icons
don't redraw until I mouse-over them. Next, I brought up a terminal window and
did "ps -A" but no output was displayed. Weird. Same thing with "ls"--no text
Comment 24 Paul Long 2007-01-17 14:32:24 EST
(In reply to comment #23)

It's all better now after installing all 190 updates. Runs fine--no redraw
problems. Sorry for the wasted bandwidth.
Comment 25 Ray Rees 2007-02-05 12:11:03 EST
Same graphical install issue w/ P3 500, ASUS P5B-F Mobo, Voodoo3 2000 AGP. Later
had lock up issue when changing to run level 5. (Old news by now).
Used Paul Long's steps above to get video working again. However, dialog boxes
afterwards weren't completely displayed; dragged mouse around areas to "paint"
the dialog box. Very strange behavior.
Got frustrated because FC5 worked well with Voodoo3.

Question: Could somebody publish a "slipstreamed" procedure for the FC6 Zod CDs
so that graphical install could be used and working 3dfx drivers are immediately

Comment 26 Ray Rees 2007-02-06 18:02:54 EST
I believe I've answered my own question.

An FC6 respin is available here:

The latest respin is based on 1/11/07 updates. I have not tested it yet. Looks
like downloads are only available via bittorrent.
Comment 27 Ray Rees 2007-02-07 23:26:59 EST
The 20070111 re-spin graphical install works on my Voodoo3 2000 HW. Suggest
using that instead of the first official FC6 release.
Comment 28 Carl Preddy 2007-02-08 19:08:49 EST
Rayrees (or others), please comment on whether your respin install is able to
run Desktop Effects (compiz/AIGLX)? I struggled long and hard to patch my
original FC6 install to be usable with a Voodoo3 2000. It now runs OK in most
respects, including running OpenGl apps like glxgears. The one that I have never
been able to beat is compiz. No wobbles or cubes for me! Thanks.
Comment 29 Ray Rees 2007-02-09 11:19:18 EST
I plan on doing a complete install of the re-spin this weekend. I only tested
whether the graphical install would successfully run the native X server, which
crashed on the Zod release.
I did read elsewhere (don't know exactly, maybe fedorasolutions) that Beryl and
possibly compiz will not run on 3dfx cards. I did notice in my xorg log for FC5
that DRI cannot run if 32 bit color depth is selected, possibly DRI will work
with 16 bit color depth?
Comment 30 Ray Rees 2007-02-12 11:35:16 EST
Re-spin installed on my P3 500 Voodoo3, but had no luck with starting
desktop-effects (compiz). Based on the stderr messages, looks like compiz cannot
run on Voodoo3 :(
However, openGL screensavers crashed prior to installing the Glide drivers. Saw
that Voodoo3 needed that as "glue" for AIGLX. Most of the openGL screensavers
worked after installing Glide.
Comment 31 Adam Jackson 2007-05-26 15:04:40 EDT
Moving to devel, but leaving in needinfo.  This should at least not be crashing
in F7.  Please test, and move back to ASSIGNED if this is still an issue in F7.
Comment 32 Matěj Cepl 2007-07-04 17:47:55 EDT
Reporter, could you please reply to the previous question? Thank you.
Comment 33 Matěj Cepl 2007-08-11 16:29:54 EDT
Reporter, could you please reply to the question in comment 31? If you won't
reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 34 Matěj Cepl 2007-09-11 20:45:12 EDT
No information requested provided, no joy for anybody -- closing this bug as
INSUFFICIENT_DATA. Reporter, if you could, please, reopen with additional

Note You need to log in before you can comment on or make changes to this bug.