Bug 212742 - gaim-guification cannot enable in gaim
gaim-guification cannot enable in gaim
Product: Fedora
Classification: Fedora
Component: gaim-guifications (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
: 214734 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-10-28 12:31 EDT by Edmond Hui
Modified: 2007-11-30 17:11 EST (History)
10 users (show)

See Also:
Fixed In Version: gaim-guifications-2.13-0.4.beta5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-09 16:57:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
diff against beta3 srpm to bump to beta5 srpm (1.55 KB, patch)
2006-12-04 10:48 EST, Gen Zhang
no flags Details | Diff

  None (edit)
Description Edmond Hui 2006-10-28 12:31:18 EDT
The plugin did not work with Gaim 2.0.0-017 beta 4, the plugin cannot be
activate, plugin details show error:

Error: You are using gtk-gaim, but this plugin require gtk. Check the plugin for
an update.

How reproducible:

install gaim-guifications plugin from Fedora Extra, run gaim and go to plugin menu
Comment 1 Heiko Adams 2006-10-30 14:23:11 EST
Same here with gaim-guifications.i386.2.13-0.3.beta3.fc6
Comment 2 Edward Rudd 2006-10-31 16:47:29 EST
This is because stock FC6 included Gaim beta3, but VERY shortly after that they
pushed out Gaim beta 4.  there is a beta4 of gaim-guifications that works with
Gaim 2.0beta4 that is available from http://gaim.guifications.org/trac/downloads
Comment 3 Heiko Adams 2006-10-31 16:57:14 EST
But wich rpm should be taken? There are only rpms for the outdated versions 1 -
3 of fedora core.
Comment 4 Jonathan Berry 2006-11-09 12:12:43 EST
*** Bug 214734 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Berry 2006-11-09 12:19:20 EST
So when can we expect to see an Extras package of the beta4 compatible
Guifications?  Can the gaim-guifications src.rpm be rebuilt with the spec file
from the beta3 Extras package?
I have this problem on x86_64 as well, so if someone can change Platform to All,
that would be more accurate.  I tried, but it would not let me.
Comment 6 cje 2006-11-14 11:52:30 EST
i thought i'd have a go at building this.  (there's a src.rpm on the page linked
in comment 2 under "Guifications2 Archive")

rpmbuild --rebuild gave two (apparently conflicting) dependency messages about
needing gaim-devel.

i did a yum install gaim-devel and that left me with just the error "gaim-devel
< 1:3 is needed..." .. i don't even know what "1:3" means there.  still,
--nodeps did the trick.

you get a similar message when you try to install the resulting rpm.  so you
can't use yum - you have to rpm -Uvh --nodeps instead.

i hope that's enough information so that someone can:

a) make a new src.rpm that doesn't give those errors?
b) make a beta4 rpm for extras.

BTW you also get the same error for the nautilus integration plugin and a
similar-ish one for the two 'gnt' plugins but i haven't looked into solving them.
Comment 7 cje 2006-11-14 12:21:26 EST
annoyingly, as soon as you install that rpm the nice new yumupdatesd pops up
telling you to 'upgrade' to the other version.  :-(

also, it's possible this version doesn't work completely.  i've tried installing
a new guifications theme and it copied the files but the new theme doesn't show
up on the theme list.
Comment 8 Gen Zhang 2006-12-04 10:48:18 EST
Created attachment 142743 [details]
diff against beta3 srpm to bump to beta5 srpm

I've rebuilt the srpm from extras with the newest version (beta5) from #2.
Seems to work.
Comment 9 Thorsten Leemhuis 2006-12-09 16:57:37 EST
(In reply to comment #8)
> Created an attachment (id=142743) [edit]
> diff against beta3 srpm to bump to beta5 srpm

Applied, slighty modified and enhanced. Thx for your help. 

Build finished, will get out with the next push -- takes normally 0-48 hours to
show up in the repos.

Tom, you are in the initial CClist according to owners.list, but not CCed to
this bug, thus I added you just FYI.

I orphaned the package officially now. New maintainer wanted.
Comment 10 Edmond Hui 2006-12-11 09:23:00 EST
yes, I just install it from the repository and it works now.

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.