Bug 212745 - Broken glibc (maybe pty?)
Broken glibc (maybe pty?)
Status: CLOSED DUPLICATE of bug 212723
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 13:08 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 03:24:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output from calling screen (83.75 KB, text/plain)
2006-10-28 13:10 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2006-10-28 13:08:00 EDT
Description of problem:
After installing latest glibc, screen just ends in an segmentation fault. After 
downgrading, everything works again.

Version-Release number of selected component (if applicable):
glibc-2.5.90-2

How reproducible:
Everytime, see above.

Actual results:
Broken glibc (maybe pty?)

Expected results:
Working stuff.

Additional info:
The strace output of screen call is attached.
Comment 1 Robert Scheck 2006-10-28 13:10:09 EDT
Created attachment 139644 [details]
strace output from calling screen
Comment 2 Michal Jaegermann 2006-10-28 13:45:31 EDT
I got something much more "interesting"; this time on x86_64.

execve("/usr/bin/newaliases", ["/usr/bin/newaliases"], [/* 32 vars */]) = 0
brk(0)                                  = 0x55555589f000
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Yes, that is the whole strace output in that particular case.  All attempts
to start  /usr/sbin/sendmail.sendmail, regardless of a name used and arguments,
are ending up in the same way.

Reverting glibc-2.5.90-2 to glibc-2.5-3 makes sendmail immediately to run.
Comment 3 Jakub Jelinek 2006-10-29 03:24:18 EST

*** This bug has been marked as a duplicate of 212723 ***
Comment 4 Horst H. von Brand 2006-10-29 18:45:14 EST
On i686, su (from coreutils-5.97-13) segfaults on me, under strace-4.5.14-3 it
tells me the (correct) password is wrong.

Note You need to log in before you can comment on or make changes to this bug.