Bug 212723 - su, sudo are Segmentation fault in normal user.
Summary: su, sudo are Segmentation fault in normal user.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
urgent
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 212745 212963 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 12:32 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 10:16:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sangu 2006-10-28 12:32:11 UTC
Description of problem:
$ sudo
Segmentation fault
]$ su
Segmentation fault


Version-Release number of selected component (if applicable):
2.5.90-2

How reproducible:
always

Steps to Reproduce:
1. $sudo or $su
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Rob Andrews 2006-10-28 16:39:10 UTC
Log in as root and run the prelink job for the day.

/etc/cron.daily/prelink

Then retry both.

I found that 'su' started working again, but 'sudo' continued to segfault.

Comment 2 Steven Usdansky 2006-10-28 18:06:07 UTC
Rob Andrew's suggestion didn't work for me - neither su nor wsudo worked.
Reverting to glibc-2.5-3 did the trick for me.

Comment 3 Jakub Jelinek 2006-10-29 08:24:31 UTC
*** Bug 212745 has been marked as a duplicate of this bug. ***

Comment 4 Jakub Jelinek 2006-10-29 08:26:35 UTC
Any suid/sgid app is broken actually, as a result of
http://sources.redhat.com/ml/libc-hacker/2006-10/msg00017.html
ld.so calls __libc_fcntl that uses SINGLE_THREAD_P before %fs resp. %gs is set
up.


Comment 6 Jim Cornette 2006-10-30 00:09:16 UTC
noting the same problem and adding to the CC.
Questioning comment #5. Is this patch going to lead to a newer package release?

Comment 7 Paul Dickson 2006-10-30 03:13:42 UTC
dovecot is also getting "killed with signal 11" when I attempt a TLS download of
E-mail.  Reverting back to glibc-2.5-3 allowed dovecot to function.

Comment 8 Jakub Jelinek 2006-10-30 10:16:34 UTC
Should be fixed in glibc-2.5.90-3 in today's rawhide.

Comment 9 Jakub Jelinek 2006-10-30 12:33:46 UTC
*** Bug 212963 has been marked as a duplicate of this bug. ***

Comment 10 Jim Cornette 2006-10-31 01:53:10 UTC
The problem is fixed. Leaving report. Thanks for quickly resolving the error.


Note You need to log in before you can comment on or make changes to this bug.