Bug 212762 - My monitor type was not detected
My monitor type was not detected
Status: CLOSED DUPLICATE of bug 231359
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 16:03 EDT by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 13:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (925 bytes, text/plain)
2007-04-02 10:26 EDT, Bruno Wolff III
no flags Details
Xorg.0.log (62.30 KB, text/plain)
2007-04-02 10:31 EDT, Bruno Wolff III
no flags Details
Xorg.0.log.old (62.27 KB, application/octet-stream)
2007-04-02 10:33 EDT, Bruno Wolff III
no flags Details
Regenerated Xorg.0.log (61.78 KB, text/plain)
2007-04-02 11:03 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2006-10-28 16:03:00 EDT
Description of problem:
After having installed FC6 I noticed my screen resolution was limited to
800x600. I had to manually go into the display config and set my monitor to NEC
Multisync LCD2010X and then I could change the resolution to 1280x1024. The
monitor is connected to a Radeon 9200 which was properly detected.

Version-Release number of selected component (if applicable):
11.1.1.3-1

How reproducible:
It happened during both practice installs I made. These were fresh installs into
spare partitions.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
A generic monitor type was used that didn't match my actual monitor very well.


Expected results:
Proper detection of the monitor.

Additional info:
Comment 1 Chris Lumens 2007-03-20 10:51:48 EDT
anaconda's just relying on whatever X tells us about the monitor these days. 
Reassigning.
Comment 2 Matěj Cepl 2007-04-02 10:05:26 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Bruno Wolff III 2007-04-02 10:26:42 EDT
Created attachment 151427 [details]
xorg.conf

This is one from an F7 snapshot install. The snapshot was from last Friday.
After doing the install, I manually changed the monitor type and that is what
is reflected in this file.
Comment 4 Bruno Wolff III 2007-04-02 10:31:39 EDT
Created attachment 151430 [details]
Xorg.0.log

This is again from a F7 install.
Comment 5 Bruno Wolff III 2007-04-02 10:33:14 EDT
Created attachment 151431 [details]
Xorg.0.log.old

Since there was a .old file there as well, I thought it would be useful to
include it.
Comment 6 Bruno Wolff III 2007-04-02 10:37:21 EDT
When I did the f7 install, I don't remember anaconda saying anything about my
monitor, though there was a message about the video card. When I tested f7, it
came up in 800x600. I don't remember exactly what the monitor name was. I then
changed it to the 2010x entry and my display changed to 1920x1280 (after logging
out and back in), which seemed odd, since that isn't a native resolution for the
monitor and isn't even the correct aspect ratio. I then changed it to use
1280x1024 and things looked normal.
Comment 7 Bruno Wolff III 2007-04-02 10:56:50 EDT
I removed the xorg.conf file from my f7 installation and booted into it. The
display resolution went back to 800x600. I checked the hardware type of the
monitor and it said "autoconfigured". I didn't retest, this, but my memory is
that I couldn't increase the resolution until after I changed the monitor type.
I'll be attaching the regenerated conf and log files shortly.
Comment 8 Bruno Wolff III 2007-04-02 11:03:36 EDT
Created attachment 151433 [details]
Regenerated Xorg.0.log

This is the Xorg.0.log from after having removed the xorg.conf file and
rebooting into f7.
Comment 9 Bruno Wolff III 2007-04-02 11:06:21 EDT
There was no etc/X11/xorg.conf created after removing it rebooting into f7,
logging in and rebooting back to fc5 (the f7 instance isn't set up to use my
internet access).
Comment 10 Matěj Cepl 2007-04-06 10:53:01 EDT
That's correct -- it was my mistake -- autoconfiguration of Xorg doesn't produce
/etc/X11/xorg.conf, only depreceated system-config-display does (because whole
idea of autoconfiguration is that /etc/X11/xorg.conf should be unnecessary).
Comment 11 Adam Jackson 2007-04-06 13:54:50 EDT

*** This bug has been marked as a duplicate of 231359 ***

Note You need to log in before you can comment on or make changes to this bug.