Bug 212765 - printer not working in fc6
printer not working in fc6
Status: CLOSED DUPLICATE of bug 212139
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 16:48 EDT by Tim Watson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 05:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Watson 2006-10-28 16:48:23 EDT
Description of problem:
HP Deskjet 720C worked in fc5 but not in fresh install of fc6. hpssd wasn't
running because it couldn't bind to socket. Adding 127.0.0.1 localhost to
/etc/hosts cured that. test print and "echo hello | lp" send job to queue
(checked with lpstat) but no signs of life from printer (it's got power!).

hplip docs show 720C to be unsupported but the fc6 system-config-printer shows
it as a valid printer (I think it uses a different driver and hpijs?).

service restarts/reboots/uninstall and reinstall printers in various
combinations doesn't help.

Version-Release number of selected component (if applicable):


How reproducible:
Don't know on other machines but on mine it's very reproducible

Steps to Reproduce:
1. install printer
2. try to print
  
Actual results:
it doesn't print

Expected results:
it does print

Additional info:
Comment 1 Tim Watson 2006-10-29 04:55:47 EST
Should have said that this is probably filed incorrectly as an hplip problem.
Perhaps cups/pnm2ppa would be better.

The seemingly relevant part of the cups error_log is as follows:

I [29/Oct/2006:08:32:35 +0000] Listening to 127.0.0.1:631 (IPv4)
I [29/Oct/2006:08:32:35 +0000] Listening to ::1:631 (IPv6)
I [29/Oct/2006:08:32:35 +0000] Listening to /var/run/cups/cups.sock (Domain)
I [29/Oct/2006:08:32:35 +0000] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2006:08:32:35 +0000] Using default TempDir of /var/spool/cups/tmp...
I [29/Oct/2006:08:32:35 +0000] Cleaning out old temporary files in "/var/spool/c
ups/tmp"...
I [29/Oct/2006:08:32:35 +0000] Configured for up to 100 clients.
I [29/Oct/2006:08:32:35 +0000] Allowing up to 100 client connections per host.
I [29/Oct/2006:08:32:35 +0000] Using policy "default" as the default!
I [29/Oct/2006:08:32:35 +0000] Full reload is required.
I [29/Oct/2006:08:32:35 +0000] Loaded MIME database from '/etc/cups': 34 types, 
38 filters...
D [29/Oct/2006:08:32:35 +0000] Loading printer lp0...
E [29/Oct/2006:08:32:35 +0000] cupsdSetPrinterAttrs: Unable to get printer conte
xt
I [29/Oct/2006:08:32:35 +0000] Loading job cache file "/var/cache/cups/job.cache
"...
D [29/Oct/2006:08:32:35 +0000] Loading job 16 from cache...
D [29/Oct/2006:08:32:35 +0000] Loading job 17 from cache...
I [29/Oct/2006:08:32:35 +0000] Full reload complete.
E [29/Oct/2006:08:32:35 +0000] Unable to find IP address for server name "buster
.watsonnet"!
Comment 2 Tim Watson 2006-10-30 17:30:25 EST
Solved (by bryancole on fedoraforum). pnm2ppa wasn't installed.

# yum install pnm2ppa

This needs fixing in the relevant package.
Comment 3 Tim Waugh 2006-10-31 05:25:09 EST

*** This bug has been marked as a duplicate of 212139 ***

Note You need to log in before you can comment on or make changes to this bug.