Bug 212927 - DWARF2 unwinder stuck at syscall_call +0x7/0xb (Core 2 Duo)
DWARF2 unwinder stuck at syscall_call +0x7/0xb (Core 2 Duo)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 00:46 EST by auywy
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 15:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description auywy 2006-10-30 00:46:12 EST
Description of problem:
Heavy compilation task - compiling KDE3.5.5 via Konstruct at console (init 3), 
no X runnning. After a while, either

(a) Lock-up. Cannot switch to other tty via Alt+F1-F4. No message captured by 
klogd or syslogd.

OR

(b) PC reboots automatically.(!)

To date, occurence ratio is like (a) - 35 times. (b) - 15 times. Only twice has 
the console printed the following message before lock-up.
-------------------------------------------------------------------

<not sure if there is anything above this because of lockup>
CPU:1
EIP: oo60[<c041a59a>] Tainted:P VLI
EFLAGS: 00010094 (2.6.18-1.2798.fc6 #1)
EIP is at resched_task +0x11/0x5f

<....snip...>

Process cc1plus (pid: 5509, ti=cdc47000 task=dfea6070 task.ti=cdc47000)

<...snip stack hex stuff...>

Call Trace:
[<c041ae55>] try_to_wake_up +0x361/0x38b
[<c04328d5>] autoremove_wake_function +0x15/0x35
[<c0419576>] __wake_up_common +0x2f/0x53
[<c04a371>] __wake_up +0x2u/0x3d
[<c0475e3b>] pipe_writev +0x393/0x411
[<c0475ed9>] pipe_write +0x20/0x24
[<c046b6f1>] vfs_write +0xa8/0x15f
[<c046bd2c>] sys_write +0x41/0x67
[<c0404027>] syscall_call +0x7/0xb

DWARF2 unwinder stuck at syscall_call +0x7/0xb

<...snip leftover inexact backtrace...>
------------------------------------------------------------
Version-Release number of selected component (if applicable):
FC6 core, default kernel 2.6.18-1.2798.fc6.
Gigabyte GA-945GM-S2 (Intel 945G+ ICH7 chipset)
Intel Core 2 Duo E6300

How reproducible:
Everytime.

Steps to Reproduce:
1. Obtain Konstruct from http://developer.kde.org/build/konstruct/stable/
konstruct-stable.tar.bz2
2. Edit gar.conf.mk to suit the platform.
3. cd meta/kdepim-crypto and make install.

  
Additional info:
I have not tested fc6 daily usage at all - just trying to test a shiny new core 
2 duo performance by giving it a big compilation task. :P Maybe this is 
reproducible for any big enough compilation task.

Have tested memory with memtest - no problems. Tried swapping around memory 
modules. Checked CPU temperature at bios after a lockup or auto-reboot - 
remained in the 35-40+ degrees range. Tried passing maxcpus=1 to kernel at 
boot. Tried many enabling/disabling various bios options. Problem still 
persists.

klogd is running at the fc6 default of klogd -x. Have edited syslogd.conf to 
log kernel messages to /var/log/kernel - but nothing useful captured.
Comment 1 Dave Jones 2006-10-31 15:20:02 EST
problems with binary modules loaded aren't debuggable.

Note You need to log in before you can comment on or make changes to this bug.