Bug 212964 - Problem with ejecting CD/DVD in KDE.
Problem with ejecting CD/DVD in KDE.
Status: CLOSED DUPLICATE of bug 212467
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-10-30 07:20 EST by Staffan Hamala
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-30 09:47:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Staffan Hamala 2006-10-30 07:20:45 EST
Description of problem:
A mounted CD (mounted by KDE/hald), can't be ejected by using the button on the
drive, or via the menu. It works if selecting unmount in the menu first, then
eject. This used to work in previous versions.

This works in Gnome, but not in KDE.

After chosing eject in the menu, the menu items for eject and unmount
disappears, so you have to make sure to chose unmount first, if you do not want
to become root and unmount manually.

Version-Release number of selected component (if applicable):
3.5.4 (the version that comes with FC6)

How reproducible:
Every time.

Steps to Reproduce:
1. Insert CD/DVD.
2. Open the disc via the icon that appears after the CD/DVD is inserted.
3. Press eject on the drive. Nothing happens.
4. Chose eject in the menu. Nothing happens.
Actual results:
The CD/DVD drive does not eject.

Expected results:
The CD/DVD drive ejects the disc.

Additional info:
I've tried this both with my normal user, and with a new user with no kde
settings at all.
Comment 1 Staffan Hamala 2006-10-30 07:41:50 EST
I just found another bug that seems to be the same thing.

[212467]: eject fails with media that have spaces in the label

I've now tried with CDs without spaces in the name, and indeed, they work as
they should.

So, is it something with KDE or eject? Why did it work in Gnome?
Comment 2 Staffan Hamala 2006-10-30 08:14:19 EST
A little log of me trying to eject the CD:
umount: /media/K3b\040data\040project: not found
eject: unmount of `/media/K3b\040data\040project' failed
c-957a71d5:~>eject /dev/hdd
umount: /media/K3b\040data\040project: not found
eject: unmount of `/media/K3b\040data\040project' failed
c-957a71d5:~>sudo eject /dev/hdd
umount: /media/K3b\040data\040project: not found
eject: unmount of `/media/K3b\040data\040project' failed
c-957a71d5:~>umount /dev/hdd
umount: /dev/hdd is not in the fstab (and you are not root)
c-957a71d5:~>sudo umount /dev/hdd
c-957a71d5:~>eject /dev/hdd
And it finally ejected the CD.
Comment 3 Ngo Than 2006-10-30 09:47:39 EST

*** This bug has been marked as a duplicate of 212467 ***

Note You need to log in before you can comment on or make changes to this bug.