Bug 2130699 - sleep mode messed up with kernel 5.19.12 on Lenovo laptop
Summary: sleep mode messed up with kernel 5.19.12 on Lenovo laptop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 36
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2132084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-28 21:46 UTC by Sammy
Modified: 2022-10-06 12:57 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-06 12:57:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal -b (371.79 KB, text/plain)
2022-09-28 21:46 UTC, Sammy
no flags Details
Journal file for 5.19.12 (333.56 KB, text/plain)
2022-09-28 22:47 UTC, Sammy
no flags Details

Description Sammy 2022-09-28 21:46:13 UTC
Created attachment 1914905 [details]
journal -b

I installed the kernel 5.19.12 from koji on my Lenovo Carbon X1 (gen 9) laptop running fully updated Fedora 36. The system works fine at start but if left alone to go to sleep (not hibernate) it does not
wake up normally. The screen keeps flashing rapidly with no response from keyboard. Only option 
being to force power down the system. Kernel 5.19.11 was working fine.

Comment 1 Sammy 2022-09-28 21:54:38 UTC
It happens even when the screen simply goes into powersave mode when the laptop is idle.

Comment 2 Sammy 2022-09-28 22:47:08 UTC
Created attachment 1914914 [details]
Journal file for 5.19.12

The previous journal was for 5.19.11

Comment 3 Hans de Goede 2022-10-01 12:31:35 UTC
I believe this is the same issue as which has been reported upstream here:
https://lore.kernel.org/regressions/YzcE%2FYEKcUDzuES%2F@kroah.com/T/

And bisected here:
https://bbs.archlinux.org/viewtopic.php?pid=2059823#p2059823

Upstream is working on this and hopefully 5.19.13 or .14 will have a fix. Until this is fixed the only advice which I have is to stick with 5.19.11 for now.

Comment 4 Hans de Goede 2022-10-01 12:33:01 UTC
Ugh, I accidentally clicked the "do not send email" checkbox below to "Save Changes" before hitting "Save Changes", so let me repeat my last comment; and this time let bugzilla actually email it to users subscribed to this bug:

I believe this is the same issue as which has been reported upstream here:
https://lore.kernel.org/regressions/YzcE%2FYEKcUDzuES%2F@kroah.com/T/

And bisected here:
https://bbs.archlinux.org/viewtopic.php?pid=2059823#p2059823

Upstream is working on this and hopefully 5.19.13 or .14 will have a fix. Until this is fixed the only advice which I have is to stick with 5.19.11 for now.

Comment 5 Benjamin Blasco 2022-10-03 11:28:09 UTC
I am also impacted by this issue, but see it occurring at boot time when connected to an external monitor.  Running Fedora 36 with kernel kernel-5.19.12-200.fc36.x86_64.  the problem does not occur when running the laptop without any external connections.  I also had to force a power down of the system when the problem occurred, and the issue is resolved by switching back to the 5.19.11-200 kernel.

Please let me know if you need me to add more info.  The same issue is also impacting my colleague @jjansson

Comment 6 Hans de Goede 2022-10-04 15:41:48 UTC
A quick update on this, the LCD panel issue should be fixed in 5.19.13, which was just released and will hopefully hit Fedora's updates-testing soon.

Note I'm not entirely sure if the mentioned problems with external monitors are really the same issue. But please do give 5.19.13 a try once available for that issue too.

Comment 7 Jan Kepler 2022-10-06 08:14:45 UTC
*** Bug 2132084 has been marked as a duplicate of this bug. ***

Comment 8 Sammy 2022-10-06 12:57:43 UTC
Fixed in 5.19.13 and 5.19.14


Note You need to log in before you can comment on or make changes to this bug.